summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-31 22:07:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-31 22:07:29 +0100
commit5a397e4f1fc191fd4b7992d0ab964cea2f3dae70 (patch)
treea3d276eb784d61c6c624be5407a16fcdfdeacd08 /dev-ml/opam-client/opam-client-2.1.2.ebuild
parentdev-ml/opam-solver: 2.1.2 bump (diff)
downloadgentoo-5a397e4f1fc191fd4b7992d0ab964cea2f3dae70.tar.gz
gentoo-5a397e4f1fc191fd4b7992d0ab964cea2f3dae70.tar.bz2
gentoo-5a397e4f1fc191fd4b7992d0ab964cea2f3dae70.zip
dev-ml/opam-client: 2.1.2 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-client/opam-client-2.1.2.ebuild')
-rw-r--r--dev-ml/opam-client/opam-client-2.1.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam-client/opam-client-2.1.2.ebuild b/dev-ml/opam-client/opam-client-2.1.2.ebuild
new file mode 100644
index 000000000000..e27961dead03
--- /dev/null
+++ b/dev-ml/opam-client/opam-client-2.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam client libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-repository-${PV}:=
+ ~dev-ml/opam-state-${PV}:=
+ ~dev-ml/opam-solver-${PV}:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( sys-apps/bubblewrap )"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}