summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-27 22:31:16 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-27 22:32:13 +0100
commit17efb8917f624dff8d79011b15defa6525dc8ab5 (patch)
tree81a5c14e9b8e2323d96e1bfcb4bd4ca6c3c33773 /dev-ml/opam
parentdev-util/glib-utils: add 2.80.5 (diff)
downloadgentoo-17efb8917f624dff8d79011b15defa6525dc8ab5.tar.gz
gentoo-17efb8917f624dff8d79011b15defa6525dc8ab5.tar.bz2
gentoo-17efb8917f624dff8d79011b15defa6525dc8ab5.zip
dev-ml/opam: add 2.2.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-2.2.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 432d802b1a0c..b1a6ce179a76 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1 +1,2 @@
DIST opam-2.1.6.tar.gz 837526 BLAKE2B 1ee60691f4fcc1011f461505942f00ff5f5cc0f0bbfc97edb8e4c676d1e4cd28fed8b49ef341af51a750848be3110713cc97e93a9e63999e4b92e7c7f68d743e SHA512 f75d81b4eb19ef6603e7a2a18e1a281ea6f5eea47b820ae888593102db5b98ded5b593b176e70235611b63a07f4a406a57fe016386f4e921f51b55eb62b9864d
+DIST opam-2.2.1.tar.gz 1089671 BLAKE2B cd6a97c8c19d7866205b49f95bf4215d986b3ad8b5d1fe5c5fd52db9b8b9e0cff8559d478e18d99d89816bbf830910f182e4c1e80719ac29a3cd5c8299450a21 SHA512 17d7d83b9de118332c121b9d3aa2e48f62a6270ea23e730a536b0f4ff060df85238c7c4ab53a89bcc3b3193d52d14358831bd9bed30a4ac699e44e4c3003b8b0
diff --git a/dev-ml/opam/opam-2.2.1.ebuild b/dev-ml/opam/opam-2.2.1.ebuild
new file mode 100644
index 000000000000..41dc7badc426
--- /dev/null
+++ b/dev-ml/opam/opam-2.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME="opam"
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" #see bugs 838658
+
+RDEPEND="
+ dev-ml/0install:=[ocamlopt?]
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/extlib:=[ocamlopt?]
+ dev-ml/jsonm:=[ocamlopt?]
+ dev-ml/ocaml-base64:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/ocaml-sha:=[ocamlopt?]
+ dev-ml/opam-0install-cudf:=[ocamlopt?]
+ dev-ml/opam-common:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/spdx_licenses:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/swhid_core:=[ocamlopt?]
+ dev-ml/uchar:=[ocamlopt?]
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile opam-solver opam-repository opam-state opam-client ${DUNE_PKG_NAME}
+}
+
+src_install() {
+ dune_src_install
+ mv "${ED}"/usr/share/doc/${PF}/${PN}/* \
+ "${ED}"/usr/share/doc/${PF} || die
+}