summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-03 03:49:04 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-03 03:49:14 +0100
commitb3b6632b81a39255e67621bad656630d5eadd3ad (patch)
tree7df7e3c5fc89bd85c3a1a8a13946e53e21a784b8 /dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild
parentnet-misc/olsrd: don't call ldconfig (fix musl install) (diff)
downloadgentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.tar.gz
gentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.tar.bz2
gentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.zip
dev-ml/ppx_deriving_yojson: new package; add version 3.6.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild')
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild
new file mode 100644
index 000000000000..603d1909b88f
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON codec generator for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving_yojson/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${PN}-${PV}-src_test_dune-ounit2.patch )
+
+RDEPEND="
+ <dev-ml/yojson-2.0.0:=
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/ppx_deriving:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"