summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-25 19:20:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-25 19:20:00 +0100
commit4aab99227ae24fb8f52268214c7acc96bbb2a8f0 (patch)
tree33d9e2ec0b9ffedbaa87209c1bdc7d08793b5fb5 /dev-ml
parentapp-portage/metagen: 0.7.3 (diff)
downloadgentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.tar.gz
gentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.tar.bz2
gentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.zip
dev-ml/luv: 0.5.11 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/luv/Manifest1
-rw-r--r--dev-ml/luv/luv-0.5.11.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/luv/Manifest b/dev-ml/luv/Manifest
index 7bbd67264ac1..f8856bf634c9 100644
--- a/dev-ml/luv/Manifest
+++ b/dev-ml/luv/Manifest
@@ -1 +1,2 @@
DIST luv-0.5.10.tar.gz 805333 BLAKE2B 23edd2bc870a2886e560d330d9a20b205a77ea7bc8ed631e00e43819474eeb75246b407113b59ed9c5f74462ad5f721338ac5a157a1fe0e443abf9ff88771089 SHA512 c50a0def366944b4ef6038503ecefe75d8e45f542311198531f01a355675c08b00370480141b455616429a883c3232d34628e6a67846db5864a1b0eabfe6311f
+DIST luv-0.5.11.tar.gz 809549 BLAKE2B 932bf48cb2d9ca32777d3c3d7457db5f4fb9dbfd51a8efbdf9282a9ebd941c53c56d7c17cf5e502c0e742dea1d1d76623d4adad32476fb36a0c08efded331f98 SHA512 8d1d7842583b02b906d89fe14bda5a66809d8ef7185efbe95e0fe7df619b795ad89fcbf16bfe1c3e92cef8721fe3d4e6192cabe215f3fe13b33de7335783e5f3
diff --git a/dev-ml/luv/luv-0.5.11.ebuild b/dev-ml/luv/luv-0.5.11.ebuild
new file mode 100644
index 000000000000..a8a5f1531183
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+HOMEPAGE="https://github.com/aantron/luv"
+SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-libs/libuv:=
+ dev-ml/ocaml-ctypes:=[ocamlopt?]
+ dev-ml/result:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gnuconfig
+ test? ( dev-ml/alcotest[ocamlopt?] )"
+
+src_prepare() {
+ default
+
+ cp "${BROOT}"/usr/share/gnuconfig/config.{guess,sub} src/c/vendor/configure/ || die
+}