summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-22 10:02:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-22 10:31:33 +0200
commit7d4c109667cedb851132a9c5de99237dac1c8acf (patch)
tree1d2581afcb418f785d487c0078866423dc630b3a /dev-ml
parentdev-ml/angstrom-lwt-unix: Remove old (diff)
downloadgentoo-7d4c109667cedb851132a9c5de99237dac1c8acf.tar.gz
gentoo-7d4c109667cedb851132a9c5de99237dac1c8acf.tar.bz2
gentoo-7d4c109667cedb851132a9c5de99237dac1c8acf.zip
dev-ml/ocsigen-toolkit: convert to opam.eclass
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild11
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild11
2 files changed, 6 insertions, 16 deletions
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
index 5099256e8dc4..9a99adeda85b 100644
--- a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit findlib
+inherit findlib opam
DESCRIPTION="User interface widgets for Ocsigen applications"
HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
@@ -29,8 +29,7 @@ RDEPEND="dev-lang/ocaml:=[ocamlopt?]
dev-ml/ppx_deriving:=
dev-ml/calendar:=
dev-ml/lwt:="
-DEPEND="${RDEPEND}
- dev-ml/opam"
+DEPEND="${RDEPEND}"
src_compile() {
emake \
@@ -42,10 +41,6 @@ src_compile() {
src_install() {
findlib_src_preinst
OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
+ opam_src_install
dodoc README.md
}
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
index 5099256e8dc4..9a99adeda85b 100644
--- a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit findlib
+inherit findlib opam
DESCRIPTION="User interface widgets for Ocsigen applications"
HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
@@ -29,8 +29,7 @@ RDEPEND="dev-lang/ocaml:=[ocamlopt?]
dev-ml/ppx_deriving:=
dev-ml/calendar:=
dev-ml/lwt:="
-DEPEND="${RDEPEND}
- dev-ml/opam"
+DEPEND="${RDEPEND}"
src_compile() {
emake \
@@ -42,10 +41,6 @@ src_compile() {
src_install() {
findlib_src_preinst
OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
+ opam_src_install
dodoc README.md
}