summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-10 03:21:31 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-15 23:15:12 +1200
commit6e01ba8b6f4e18bc758fee80cfd4a9f86af801d5 (patch)
tree74bfe9271bd10d15601d409aa5d6a6285b8cb963 /dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild
parentwww-client/vivaldi: Old. (diff)
downloadgentoo-6e01ba8b6f4e18bc758fee80cfd4a9f86af801d5.tar.gz
gentoo-6e01ba8b6f4e18bc758fee80cfd4a9f86af801d5.tar.bz2
gentoo-6e01ba8b6f4e18bc758fee80cfd4a9f86af801d5.zip
dev-perl/Convert-UUlib: Add IUSE="system-uulib" and disable unbundling
Gentoo's uulib implementation and the bundled version differ in some way, making Gentoo's version less stable, causing mislinked .so files as seen in bug #559930 This pragmatic solution just defers this problem to the user so those who care about system purity can do that at their own cost, while making the default workflow both Work(tm) and Work as Upstream Intended. R1-bump required as it is expected people who have existing installations and did not run tests will have a broken installation, which can be confirmed by running: /usr/bin/perl -MConvert::UUlib=:all \ -e'SetFNameFilter(sub {});FNameFilter(1);SetFNameFilter()' Bug: https://bugs.gentoo.org/559930 Package-Manager: portage-2.3.0 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild')
-rw-r--r--dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild b/dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild
new file mode 100644
index 000000000000..525945a9ea4f
--- /dev/null
+++ b/dev-perl/Convert-UUlib/Convert-UUlib-1.500.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MLEHMANN
+MODULE_VERSION=1.5
+inherit perl-module
+
+DESCRIPTION="A Perl interface to the uulib library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="system-uulib test"
+
+RDEPEND="
+ system-uulib? ( >=dev-libs/uulib-0.5.20-r1 )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+ dev-perl/Canary-Stability
+"
+
+SRC_TEST="do parallel"
+
+src_prepare() {
+ if use system-uulib; then
+ epatch "${FILESDIR}/${P}-unbundle.patch"
+ ewarn "Building with USE=system-uulib known to be problematic and cause"
+ ewarn " Convert::UUlib to segfault when used. ( Bug #559930 )"
+ use test || ewarn "use of FEATURES=test strongly recommended";
+ fi
+ perl-module_src_prepare
+}