summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-24 01:01:39 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-24 01:01:58 +1300
commit76683f11c522943094583f662a61c2e804f24bfe (patch)
treec8123dff4c1fa1de6388620d646db5a63100baba /dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild
parentsys-apps/prefix-chain-utils: prefer /lib/gentoo/functions.sh (diff)
downloadgentoo-76683f11c522943094583f662a61c2e804f24bfe.tar.gz
gentoo-76683f11c522943094583f662a61c2e804f24bfe.tar.bz2
gentoo-76683f11c522943094583f662a61c2e804f24bfe.zip
dev-perl/File-ShareDir-ProjectDistDir: Bump to version 1.0.9
Upstream: - Fix bugs with '.' in @INC Bug: https://bugs.gentoo.org/613614 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild')
-rw-r--r--dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild b/dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild
new file mode 100644
index 000000000000..263ad860c8c8
--- /dev/null
+++ b/dev-perl/File-ShareDir-ProjectDistDir/File-ShareDir-ProjectDistDir-1.0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KENTNL
+DIST_VERSION=1.000009
+inherit perl-module
+
+DESCRIPTION="Simple set-and-forget using of a '/share' directory in your projects root"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? ( >=dev-perl/Path-Tiny-0.58.0 )
+ virtual/perl-Carp
+ dev-perl/File-ShareDir
+ dev-perl/Path-FindDev
+ dev-perl/Path-IsDev
+ dev-perl/Path-Tiny
+ dev-perl/Sub-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ !minimal? ( >=virtual/perl-ExtUtils-MakeMaker-7.0.0 )
+ test? (
+ !minimal? (
+ >=dev-perl/Capture-Tiny-0.120.0
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=virtual/perl-Test-Simple-0.990.0
+ )
+ dev-perl/Class-Tiny
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"