summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-16 06:40:33 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-16 21:25:55 +0200
commit528fc65e10a9e2365abb8033d39a7081d6d6792c (patch)
tree73088de7cbf51f95fde7a7a3d92f0caa1edf358c /dev-perl/File-pushd/File-pushd-1.9.0.ebuild
parentdev-perl/Test-TCP: Bump to version 2.160.0 (diff)
downloadgentoo-528fc65e10a9e2365abb8033d39a7081d6d6792c.tar.gz
gentoo-528fc65e10a9e2365abb8033d39a7081d6d6792c.tar.bz2
gentoo-528fc65e10a9e2365abb8033d39a7081d6d6792c.zip
dev-perl/File-pushd: Bump to version 1.9.0
- EAPI6 Upstream: - Object destruction stops clobbering $@ - Tests fixed Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/File-pushd/File-pushd-1.9.0.ebuild')
-rw-r--r--dev-perl/File-pushd/File-pushd-1.9.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/File-pushd/File-pushd-1.9.0.ebuild b/dev-perl/File-pushd/File-pushd-1.9.0.ebuild
new file mode 100644
index 000000000000..f72ce8856ad2
--- /dev/null
+++ b/dev-perl/File-pushd/File-pushd-1.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.009
+inherit perl-module
+
+DESCRIPTION="Change directory temporarily for a limited scope"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-version
+ )
+"