summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-25 07:18:04 +0100
committerSam James <sam@gentoo.org>2024-05-25 07:21:48 +0100
commit3842db814612481f5efb1320c1aab404fae09a40 (patch)
treef4137ec4d802d44fb296d40fd51bb16cb0c1c698 /dev-perl/GnuPG-Interface/files
parentdev-python/pytest-xdist: Remove old (diff)
downloadgentoo-3842db814612481f5efb1320c1aab404fae09a40.tar.gz
gentoo-3842db814612481f5efb1320c1aab404fae09a40.tar.bz2
gentoo-3842db814612481f5efb1320c1aab404fae09a40.zip
dev-perl/GnuPG-Interface: don't call which
We don't want to rely on sys-apps/which and it doesn't serve much purpose to do this check at all. We already die if we can't find the gpg version on the next line anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/GnuPG-Interface/files')
-rw-r--r--dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch b/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch
new file mode 100644
index 000000000000..5e7f8b6a3efe
--- /dev/null
+++ b/dev-perl/GnuPG-Interface/files/GnuPG-Interface-1.30.0-which-hunt.patch
@@ -0,0 +1,16 @@
+We don't want to rely on sys-apps/which and it doesn't serve much purpose
+to do this check at all. We already die if we can't find the gpg version
+on the next line anyway.
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -3,10 +3,6 @@ use strict;
+ use warnings;
+ use inc::Module::Install;
+
+-print "which gpg ... ";
+-system("which", "gpg");
+-die "gpg (GnuPG) not found" if ( $? != 0 );
+-
+ my $output = `gpg --version`;
+ die "Can't determine gpg version"
+ unless $output =~ /^gpg \(GnuPG.*?\) (\d+\.\d+)/;