summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild')
-rw-r--r--dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild b/dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild
new file mode 100644
index 000000000000..ca0c488681d4
--- /dev/null
+++ b/dev-perl/Lab-Measurement/Lab-Measurement-3.410.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ "${PV}" != "9999" ]]; then
+ MODULE_VERSION=3.41 # change this!!!
+ MODULE_AUTHOR="AKHUETTEL"
+ KEYWORDS="~amd64 ~x86"
+ inherit perl-module
+else
+ EGIT_REPO_URI="https://github.com/lab-measurement/lab-measurement.git"
+ EGIT_BRANCH="master"
+ EGIT_SOURCEDIR=${S}
+ S=${WORKDIR}/${P}/Measurement
+ inherit perl-module git-2
+fi
+
+DESCRIPTION="Measurement control and automation with Perl"
+HOMEPAGE="http://www.labmeasurement.de/"
+
+# this is perl's license, whatever it means
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+IUSE="debug +xpression"
+
+RDEPEND="
+ dev-perl/Class-ISA
+ dev-perl/Clone
+ dev-perl/Exception-Class
+ dev-perl/Hook-LexWrap
+ dev-perl/List-MoreUtils
+ dev-perl/Term-ANSIScreen
+ dev-perl/TermReadKey
+ dev-perl/TeX-Encode
+ dev-perl/XML-Generator
+ dev-perl/XML-DOM
+ dev-perl/XML-Twig
+ dev-perl/encoding-warnings
+ dev-perl/yaml
+ dev-perl/Switch
+ sci-visualization/gnuplot
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Time-HiRes
+ !dev-perl/Lab-Instrument
+ !dev-perl/Lab-Tools
+ debug? (
+ dev-lang/perl[ithreads]
+ dev-perl/wxperl
+ )
+ xpression? (
+ dev-perl/wxperl
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build
+"
+
+pkg_postinst() {
+ if ( ! has_version sci-libs/linuxgpib ) && ( ! has_version dev-perl/Lab-VISA ) ; then
+ elog "You may want to install one or more backend driver modules. Supported are"
+ elog " sci-libs/linuxgpib Open-source GPIB hardware driver"
+ elog " dev-perl/Lab-VISA Bindings for the NI proprietary VISA driver"
+ elog " stack (dilfridge overlay)"
+ fi
+}