summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-05 09:42:49 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-05 21:32:32 +0100
commit58f64b0fc79695209b50ae2415cf679ba2215892 (patch)
treeb1abea0cdf4ff5eb7626da8eff8452ed96cc2ca5 /dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild
parentdev-perl/Net-OpenSSH: Bump to version 0.700.0 (diff)
downloadgentoo-58f64b0fc79695209b50ae2415cf679ba2215892.tar.gz
gentoo-58f64b0fc79695209b50ae2415cf679ba2215892.tar.bz2
gentoo-58f64b0fc79695209b50ae2415cf679ba2215892.zip
dev-perl/Net-SFTP-Foreign: Bump to version 1.810.0
- EAPI6 - Dep fixup for ssh - Tests patched to test against an sftp server - Examples now installable Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild')
-rw-r--r--dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild b/dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild
new file mode 100644
index 000000000000..a68857c7f85d
--- /dev/null
+++ b/dev-perl/Net-SFTP-Foreign/Net-SFTP-Foreign-1.810.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=1.81
+inherit perl-module
+
+DESCRIPTION="SSH File Transfer Protocol client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test examples"
+
+PATCHES=(
+ # https://rt.cpan.org/Ticket/Display.html?id=112709
+ "${FILESDIR}/${DIST_VERSION}-test-server-path.patch"
+)
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Time-HiRes
+ virtual/ssh
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}