summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-11 23:47:33 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-11 23:48:42 +0200
commitba305a5449a81f30db693d93f300145943385b90 (patch)
tree9f2e724fe971a3a4b8c1f29d16c0f910163e6866 /dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
parentperl-module.eclass: Add new control variable DIST_EXAMPLES (diff)
downloadgentoo-ba305a5449a81f30db693d93f300145943385b90.tar.gz
gentoo-ba305a5449a81f30db693d93f300145943385b90.tar.bz2
gentoo-ba305a5449a81f30db693d93f300145943385b90.zip
dev-perl/Net-SSH2: Add example ebuild for new perl-module.eclass features
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
new file mode 100644
index 000000000000..d77d3ef7a8cd
--- /dev/null
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.58
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Support for the SSH 2 protocol via libssh2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt libressl"
+
+RDEPEND="
+ sys-libs/zlib
+ net-libs/libssh2
+ !gcrypt? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ gcrypt? (
+ dev-libs/libgcrypt:0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-Constant
+ >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+src_configure() {
+ use gcrypt && myconf=gcrypt
+ perl-module_src_configure
+}