summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-19 20:17:49 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 23:41:50 +0100
commitfd9a2b49784ee3b677f84a6a8fa4c2c1d3d5d97b (patch)
tree22d2cc3dce88f01aa37622f905b994def00f343b /dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild
parentdev-perl/perltidy: Remove from tree, gone to dev-perl/Perl-Tidy (diff)
downloadgentoo-fd9a2b49784ee3b677f84a6a8fa4c2c1d3d5d97b.tar.gz
gentoo-fd9a2b49784ee3b677f84a6a8fa4c2c1d3d5d97b.tar.bz2
gentoo-fd9a2b49784ee3b677f84a6a8fa4c2c1d3d5d97b.zip
dev-perl/Perl-Tidy: Bump to version 20160302.0.0
- EAPI6 - Fix LICENSE - Install stylekey and tutorial - Make examples optional on USE="examples" Upstream: - Fix handliong of long-form --nostack-closing-tokens - Explicit "assume utf8" support flag - Removed unwanted continuation indentation - Fixed crash w/ --output-line-ending - Fixed misparse of //= construct - Fixed misparse of // - Fixed bug with "else" warnining inside a "switch" statement. - Added "-xs" flag for extended syntax ala MX::Declare style. - "-boc" vertical alignment fixed. - Support upcomming bitwise string operators. - "-io" and "-dac" can now be used together. - Support for regex "/n" - non-global warnings - Perl5.22 Signatures support - Removed unwanted newline after anonymous sub Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild
new file mode 100644
index 000000000000..1149c66c4d11
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20160302.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20160302
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r "${S}"/examples/*
+ fi
+}