summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/SGMLSpm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/SGMLSpm/files')
-rw-r--r--dev-perl/SGMLSpm/files/Makefile.PL17
-rw-r--r--dev-perl/SGMLSpm/files/sgmlspl.patch11
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/SGMLSpm/files/Makefile.PL b/dev-perl/SGMLSpm/files/Makefile.PL
new file mode 100644
index 000000000000..a2508c0a9afb
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/Makefile.PL
@@ -0,0 +1,17 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'SGMLS',
+ 'VERSION' => '1.03ii',
+ 'PM' => { 'SGMLS.pm' => '$(INST_LIBDIR)/SGMLS.pm',
+ 'Output.pm' => '$(INST_LIBDIR)/SGMLS/Output.pm',
+ 'Refs.pm' => '$(INST_LIBDIR)/SGMLS/Refs.pm',
+ 'skel.pl' => '$(INST_LIBDIR)/sgmlspl-specs/skel.pl',
+ },
+ 'MAN3PODS'=> { 'SGMLS.pm' => '$(INST_MAN3DIR)/SGMLS.3pm',
+ 'Output.pm' => '$(INST_MAN3DIR)/SGMLS::Output.3pm',
+ 'Refs.pm' => '$(INST_MAN3DIR)/SGMLS::Refs.3pm',
+ },
+ 'EXE_FILES' => [ 'sgmlspl', ],
+);
diff --git a/dev-perl/SGMLSpm/files/sgmlspl.patch b/dev-perl/SGMLSpm/files/sgmlspl.patch
new file mode 100644
index 000000000000..946ce319a97d
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/sgmlspl.patch
@@ -0,0 +1,11 @@
+--- SGMLSpm/sgmlspl.pl.old 2008-08-23 17:06:13.000000000 +0200
++++ SGMLSpm/sgmlspl.pl 2008-08-23 17:07:13.000000000 +0200
+@@ -238,7 +238,7 @@
+ package main;
+
+ $ARGV = shift;
+-unless ($ARGV eq '' || do $ARGV) {
++unless ($ARGV eq '' || do 'sgmlspl-specs/' . $ARGV || do $ARGV) {
+ if (!-e $ARGV) {
+ die "FATAL: $ARGV does not exist.\n";
+ } elsif (!-r $ARGV) {