summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:28:52 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:28:52 -0400
commit18a04ee5dc437bd1682b0688d5fa67baf0aea60a (patch)
tree012b3e1676a54a21758c355fe0be9e7e8e65cb5f /dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild
parentapp-text/xapian-omega: version bump to 1.2.23 (diff)
downloadgentoo-18a04ee5dc437bd1682b0688d5fa67baf0aea60a.tar.gz
gentoo-18a04ee5dc437bd1682b0688d5fa67baf0aea60a.tar.bz2
gentoo-18a04ee5dc437bd1682b0688d5fa67baf0aea60a.zip
dev-perl/Search-Xapian: version bump to 1.2.23.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild
new file mode 100644
index 000000000000..3a1c0d52e784
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MODULE_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="dev-libs/xapian:0/1.2.22
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+SRC_TEST="do"
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}