summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 15:58:48 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 15:58:48 +1300
commit3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915 (patch)
tree5df2e1826409d0f17303a7708fe715ab9be7f7d8 /dev-perl/XML-Compile
parentdev-perl/XML-CompactTree-XS: Bump to version 0.30.0 (diff)
downloadgentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.tar.gz
gentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.tar.bz2
gentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.zip
dev-perl/XML-Compile: Bump to version 1.600.0
Upstream: - Improve seperation of lexical-space and value-space facets - Fix json_friendly enumeration and pattern facets - Fix early facet on missing field - Require newer Log::Report - Move json regression tests to being author tests - Accept non-ascii word characters in NCName type - use facets with nested simpletypes Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-Compile')
-rw-r--r--dev-perl/XML-Compile/Manifest1
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/Manifest b/dev-perl/XML-Compile/Manifest
index 2776838e5f83..f0892707d518 100644
--- a/dev-perl/XML-Compile/Manifest
+++ b/dev-perl/XML-Compile/Manifest
@@ -1,2 +1,3 @@
DIST XML-Compile-1.54.tar.gz 205002 BLAKE2B ac3bb51453f51b5974955668cdca0faf7020934f6cd68cf1ec3f251921b521bc5f7980cb0d6754bbf3a231be06b7908e625d6f66420b3539d0fb3d5bf9bf0c2f SHA512 824318d0c941cd3e17f6c7396b815675f87fa03c5b17de6e2a71cfeefcffec8b2f050b1c6d63e013726a3d57cfc76c4ee29dbde14b91a6b1500341dd9c5e7310
DIST XML-Compile-1.56.tar.gz 207239 BLAKE2B b577947e90b3071a3643bb733b265d95f2f2dce409fa5975ea4cd94e3b1fc7a2984cf8be095dee209a8fb287269b666664b452a3dcb6a5eec67969713f8091a8 SHA512 bd33651aba2270b7d2d61b4660ced63c8979f21d6852001cfbde24f192f52677c92b8fcce1597cc28da4d1791d5f609f8b77b5065d4860545543cdee6e138e9f
+DIST XML-Compile-1.60.tar.gz 209090 BLAKE2B 215c043b84f46583cedf12b8be2ed48ce29ce0da45fddbb50135ea0685a3504baba22d61b463e42cfd2090514675396c6e6c400722bdf85b2f9d3a9f59a09015 SHA512 361666004b61bbdf07f62421239120256de3cbf5f17da532c7bab5c8fc9c057638dbf2c26604f8ecea3ef1301364dd945ccc9cbddc358096962d4c289009b61b
diff --git a/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild
new file mode 100644
index 000000000000..a4b3b79c2a94
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.60
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=dev-perl/Log-Report-1.200.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ dev-perl/Types-Serialiser
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-LibXML-2.10.700
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}