summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-09-05 21:08:40 +0300
committerSam James <sam@gentoo.org>2024-09-05 20:32:50 +0100
commit8815b1468e8082b5c6e13349cd5263e5562b1984 (patch)
tree80d58da8c355af66379e264cb93dc6db90c06e1b /dev-perl
parentdev-perl/Wx-Scintilla: respect user flags (diff)
downloadgentoo-8815b1468e8082b5c6e13349cd5263e5562b1984.tar.gz
gentoo-8815b1468e8082b5c6e13349cd5263e5562b1984.tar.bz2
gentoo-8815b1468e8082b5c6e13349cd5263e5562b1984.zip
dev-perl/Wx-Scintilla: force c++11 due to std::auto_ptr
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r5.ebuild1
-rw-r--r--dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.39-force-c++11.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r5.ebuild b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r5.ebuild
index 65cb495b5f83..dd6c3c1fe734 100644
--- a/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r5.ebuild
+++ b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r5.ebuild
@@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.34-flags.patch
"${FILESDIR}"/${PN}-0.39-gcc6.patch
"${FILESDIR}"/${PN}-0.39-respect-user-flags.patch
+ "${FILESDIR}"/${PN}-0.39-force-c++11.patch
)
src_configure() {
diff --git a/dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.39-force-c++11.patch b/dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.39-force-c++11.patch
new file mode 100644
index 000000000000..92a5af0c4892
--- /dev/null
+++ b/dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.39-force-c++11.patch
@@ -0,0 +1,13 @@
+Uses std::auto_ptr which has been officially removed in C++17.
+While GCC still has it present LLVM has explicitly removed it.
+
+--- a/inc/Module/Build/Scintilla/GTK.pm
++++ b/inc/Module/Build/Scintilla/GTK.pm
+@@ -50,6 +50,7 @@
+ '-o ' . $object_name,
+ '-O2',
+ '-Wall',
++ '-std=c++11',
+ $object_name !~ /((Plat|Scintilla)WX|scintilla)\.o/
+ ? '-Wno-missing-braces -Wno-char-subscripts'
+ : '',