summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-Mail_Mime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-Mail_Mime')
-rw-r--r--dev-php/PEAR-Mail_Mime/Manifest1
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.8.ebuild16
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch74
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch74
-rw-r--r--dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch76
-rw-r--r--dev-php/PEAR-Mail_Mime/metadata.xml5
6 files changed, 246 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/Manifest b/dev-php/PEAR-Mail_Mime/Manifest
new file mode 100644
index 000000000000..24fe83ec6b1a
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/Manifest
@@ -0,0 +1 @@
+DIST Mail_Mime-1.8.8.tgz 32059 SHA256 d1a7fb767ebdabef6b8d346911a0f91fc2bb23df36175cf036474f5ed942ced1 SHA512 c2d9735041f61ca7b7addbf4deae09e6b7448f3d34143fe10d49152802f100db2c29dcf9e8938010f275c38630b849c8e45bb2db54eed6504e8425669a18d0b8 WHIRLPOOL 573133f646decf3f88728c80c381efb1b4d307575c33bed6b53eb09f0b313352813b5364081be39166dcd7335480f89e6c861599b9f894aa083bc88614c6b39b
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.8.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.8.ebuild
new file mode 100644
index 000000000000..dd19651b8724
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.8.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides classes to deal with creation and manipulation of mime messages"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+PDEPEND="dev-php/PEAR-Mail_mimeDecode"
diff --git a/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
new file mode 100644
index 000000000000..b18e4c642514
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
@@ -0,0 +1,74 @@
+--- mime.php.orig 2007-08-16 12:16:47.000000000 +0200
++++ mime.php 2007-08-16 12:25:07.000000000 +0200
+@@ -376,7 +376,7 @@
+ * @return string contents of $file_name
+ * @access private
+ */
+- function &_file2str($file_name)
++ function _file2str($file_name)
+ {
+ if (!is_readable($file_name)) {
+ $err = PEAR::raiseError('File is not readable ' . $file_name);
+@@ -413,7 +413,7 @@
+ * @return object The text mimePart object
+ * @access private
+ */
+- function &_addTextPart(&$obj, $text)
++ function _addTextPart(&$obj, $text)
+ {
+ $params['content_type'] = 'text/plain';
+ $params['encoding'] = $this->_build_params['text_encoding'];
+@@ -437,7 +437,7 @@
+ * @return object The html mimePart object
+ * @access private
+ */
+- function &_addHtmlPart(&$obj)
++ function _addHtmlPart(&$obj)
+ {
+ $params['content_type'] = 'text/html';
+ $params['encoding'] = $this->_build_params['html_encoding'];
+@@ -459,7 +459,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addMixedPart()
++ function _addMixedPart()
+ {
+ $params = array();
+ $params['content_type'] = 'multipart/mixed';
+@@ -480,7 +480,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addAlternativePart(&$obj)
++ function _addAlternativePart(&$obj)
+ {
+ $params['content_type'] = 'multipart/alternative';
+ if (is_object($obj)) {
+@@ -502,7 +502,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addRelatedPart(&$obj)
++ function _addRelatedPart(&$obj)
+ {
+ $params['content_type'] = 'multipart/related';
+ if (is_object($obj)) {
+@@ -523,7 +523,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addHtmlImagePart(&$obj, $value)
++ function _addHtmlImagePart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = 'base64';
+@@ -546,7 +546,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addAttachmentPart(&$obj, $value)
++ function _addAttachmentPart(&$obj, $value)
+ {
+ $params['dfilename'] = $value['name'];
+ $params['encoding'] = $value['encoding'];
diff --git a/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
new file mode 100644
index 000000000000..ab87c19287e6
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
@@ -0,0 +1,74 @@
+--- a/Mail/mime.php.orig 2007-08-16 12:16:47.000000000 +0200
++++ b/Mail/mime.php 2007-08-16 12:25:07.000000000 +0200
+@@ -376,7 +376,7 @@
+ * @return string contents of $file_name
+ * @access private
+ */
+- function &_file2str($file_name)
++ function _file2str($file_name)
+ {
+ if (!is_readable($file_name)) {
+ $err = PEAR::raiseError('File is not readable ' . $file_name);
+@@ -413,7 +413,7 @@
+ * @return object The text mimePart object
+ * @access private
+ */
+- function &_addTextPart(&$obj, $text)
++ function _addTextPart(&$obj, $text)
+ {
+ $params['content_type'] = 'text/plain';
+ $params['encoding'] = $this->_build_params['text_encoding'];
+@@ -437,7 +437,7 @@
+ * @return object The html mimePart object
+ * @access private
+ */
+- function &_addHtmlPart(&$obj)
++ function _addHtmlPart(&$obj)
+ {
+ $params['content_type'] = 'text/html';
+ $params['encoding'] = $this->_build_params['html_encoding'];
+@@ -459,7 +459,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addMixedPart()
++ function _addMixedPart()
+ {
+ $params = array();
+ $params['content_type'] = 'multipart/mixed';
+@@ -480,7 +480,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addAlternativePart(&$obj)
++ function _addAlternativePart(&$obj)
+ {
+ $params['content_type'] = 'multipart/alternative';
+ if (is_object($obj)) {
+@@ -502,7 +502,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addRelatedPart(&$obj)
++ function _addRelatedPart(&$obj)
+ {
+ $params['content_type'] = 'multipart/related';
+ if (is_object($obj)) {
+@@ -523,7 +523,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addHtmlImagePart(&$obj, $value)
++ function _addHtmlImagePart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = 'base64';
+@@ -546,7 +546,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addAttachmentPart(&$obj, $value)
++ function _addAttachmentPart(&$obj, $value)
+ {
+ $params['dfilename'] = $value['name'];
+ $params['encoding'] = $value['encoding'];
diff --git a/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch
new file mode 100644
index 000000000000..677e67117a3c
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch
@@ -0,0 +1,76 @@
+--- mime.php 2005-07-13 22:49:04.000000000 +0200
++++ mime.php 2006-03-07 12:22:41.000000000 +0100
+@@ -309,7 +309,7 @@
+ * @return object The text mimePart object
+ * @access private
+ */
+- function &_addTextPart(&$obj, $text)
++ function _addTextPart(&$obj, $text)
+ {
+ $params['content_type'] = 'text/plain';
+ $params['encoding'] = $this->_build_params['text_encoding'];
+@@ -330,7 +330,7 @@
+ * @return object The html mimePart object
+ * @access private
+ */
+- function &_addHtmlPart(&$obj)
++ function _addHtmlPart(&$obj)
+ {
+ $params['content_type'] = 'text/html';
+ $params['encoding'] = $this->_build_params['html_encoding'];
+@@ -350,7 +350,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addMixedPart()
++ function _addMixedPart()
+ {
+ $params['content_type'] = 'multipart/mixed';
+ return new Mail_mimePart('', $params);
+@@ -366,7 +366,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addAlternativePart(&$obj)
++ function _addAlternativePart(&$obj)
+ {
+ $params['content_type'] = 'multipart/alternative';
+ if (is_object($obj)) {
+@@ -386,7 +386,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addRelatedPart(&$obj)
++ function _addRelatedPart(&$obj)
+ {
+ $params['content_type'] = 'multipart/related';
+ if (is_object($obj)) {
+@@ -405,7 +405,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addHtmlImagePart(&$obj, $value)
++ function _addHtmlImagePart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = 'base64';
+@@ -424,7 +424,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addAttachmentPart(&$obj, $value)
++ function _addAttachmentPart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = $value['encoding'];
+--- mimePart.php 2004-12-11 00:08:26.000000000 +0100
++++ mimePart.php 2006-03-07 12:22:41.000000000 +0100
+@@ -261,7 +261,7 @@
+ * otherwise you will not be able to add further subparts.
+ * @access public
+ */
+- function &addSubPart($body, $params)
++ function addSubPart($body, $params)
+ {
+ $this->_subparts[] = new Mail_mimePart($body, $params);
+ return $this->_subparts[count($this->_subparts) - 1];
diff --git a/dev-php/PEAR-Mail_Mime/metadata.xml b/dev-php/PEAR-Mail_Mime/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>