summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:28:12 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:35:11 -0400
commitf35f92faa0a03b0aeae727ff74efecf792404fa7 (patch)
tree9fb6bf6fc4db23a8e19798fe80a4e15039e508f3 /dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild
parentgui-wm/tinywl: Keyword 0.17.3 x86, #934028 (diff)
downloadgentoo-f35f92faa0a03b0aeae727ff74efecf792404fa7.tar.gz
gentoo-f35f92faa0a03b0aeae727ff74efecf792404fa7.tar.bz2
gentoo-f35f92faa0a03b0aeae727ff74efecf792404fa7.zip
dev-php/PEAR-Net_Sieve: add 1.4.7
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild')
-rw-r--r--dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild
new file mode 100644
index 000000000000..9d8c2edcc04f
--- /dev/null
+++ b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.4.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~s390 ~sparc ~x86"
+IUSE="sasl"
+
+RDEPEND="dev-php/PEAR-Net_Socket
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+src_install() {
+ insinto /usr/share/php/Net
+ doins Sieve.php
+ php-pear-r2_install_packagexml
+}