summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-PEAR
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-PEAR')
-rw-r--r--dev-php/PEAR-PEAR/Manifest2
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild109
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.9.5.ebuild108
-rw-r--r--dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix-v2.patch15
-rw-r--r--dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix.patch31
-rw-r--r--dev-php/PEAR-PEAR/files/pear.conf2
-rw-r--r--dev-php/PEAR-PEAR/files/pear.conf-r12
-rw-r--r--dev-php/PEAR-PEAR/files/pear.conf-r22
-rw-r--r--dev-php/PEAR-PEAR/metadata.xml5
9 files changed, 276 insertions, 0 deletions
diff --git a/dev-php/PEAR-PEAR/Manifest b/dev-php/PEAR-PEAR/Manifest
new file mode 100644
index 000000000000..fc2dbfc55046
--- /dev/null
+++ b/dev-php/PEAR-PEAR/Manifest
@@ -0,0 +1,2 @@
+DIST PEAR-1.9.4.tgz 296332 SHA256 80c329264a0363c6222b2f750e1646015161c9787bb4041f5ab41d95160bb93c SHA512 f4c8c6f24039940254cf774e51087a12e6b17f7cbd7308c814f8b43f1342ae68db6b2d94626a4d7ed05e8b537816da08459e2939689f15aef725504683657f47 WHIRLPOOL a640fa5dff5eda2801698094b3d99c7c63d9028727f323634dc6c17942d4cbf4fe76ddd35b89a11a8187de068201b875642bf90ea705544801d4ffaac3325828
+DIST PEAR-1.9.5.tgz 290006 SHA256 d4c27d7321f76527222eae3972c6ffb62412cc729105c858ae0bb0861d699bdb SHA512 73c5ef84c4ededa7bca81b1d94944e80ddf9dc40101c0727c5975d4ddb72f66a28aecafcefb7af8d1cc3b6fa7e488e704559a7efbebe860adfb8e9796cdf4933 WHIRLPOOL ea42f63e73d680985857f3e8e318e1f7d001edc843d12b94c9b7d3969c0793c0a9709d2dc8940b339be2f9e854cb2a3acb8c0e5cdef7ddc3cd06c9df97a3ee37
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild
new file mode 100644
index 000000000000..293683c7e16c
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+PEAR="${PV}"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+DESCRIPTION="PEAR Base System"
+HOMEPAGE="http://pear.php.net/package/PEAR"
+SRC_URI="http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ dev-lang/php[cli,xml,zlib]"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="dev-php/pear"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="${EPREFIX}/var/cache/pear"
+ [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="${EPREFIX}/var/tmp/pear"
+ [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="${EPREFIX}/tmp"
+
+ elog
+ elog "cache_dir is set to: ${PEAR_CACHEDIR}"
+ elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
+ elog "temp_dir is set to: ${PEAR_TEMPDIR}"
+ elog
+ elog "If you want to change the above values, you need to set"
+ elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
+ elog "accordingly in /etc/portage/make.conf and re-emerge ${PN}."
+ elog
+}
+
+src_prepare() {
+ cd PEAR-${PV}
+ epatch "${FILESDIR}/gentoo-libtool-mismatch-fix.patch"
+
+}
+
+src_install() {
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ # install PEAR package
+ cd "${S}"/PEAR-${PEAR}
+
+ insinto /usr/share/php
+ doins -r PEAR/
+ doins -r OS/
+ doins PEAR.php PEAR5.php System.php
+ doins scripts/pearcmd.php
+ doins scripts/peclcmd.php
+
+ newbin scripts/pear.sh pear
+ newbin scripts/peardev.sh peardev
+ newbin scripts/pecl.sh pecl
+
+ # adjust some scripts for current version
+ for i in pearcmd.php peclcmd.php ; do
+ sed "s:@pear_version@:${PEAR}:g" -i "${D}/usr/share/php/${i}"
+ done
+
+ for i in pear peardev pecl ; do
+ sed "s:@bin_dir@:${EPREFIX}/usr/bin:g" -i "${D}/usr/bin/${i}"
+ sed "s:@php_dir@:${EPREFIX}/usr/share/php:g" -i "${D}/usr/bin/${i}"
+ done
+ sed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" -i "${D}/usr/bin/pear"
+
+ sed "s:@package_version@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Command/Package.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Dependency2.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v1.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v2.php"
+
+ # finalize install
+ insinto /etc
+ newins "${FILESDIR}"/pear.conf-r2 pear.conf
+ sed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" -i "${D}/etc/pear.conf"
+
+ # Change the paths for eprefix!
+ sed "s|s:19:\"/usr/share/php/docs\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/docs\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:19:\"/usr/share/php/data\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/data\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:20:\"/usr/share/php/tests\"|s:$(( ${#EPREFIX}+20 )):\"${EPREFIX}/usr/share/php/tests\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:14:\"/usr/share/php\"|s:$(( ${#EPREFIX}+14 )):\"${EPREFIX}/usr/share/php\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:8:\"/usr/bin\"|s:$(( ${#EPREFIX}+8 )):\"${EPREFIX}/usr/bin\"|g" -i "${D}/etc/pear.conf"
+
+ [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR#${EPREFIX}}"
+ keepdir "${PEAR_CACHEDIR#${EPREFIX}}"
+ diropts -m1777
+ keepdir "${PEAR_DOWNLOADDIR#${EPREFIX}}"
+}
+
+pkg_preinst() {
+ rm -f "${EROOT}/etc/pear.conf"
+}
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.5.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.5.ebuild
new file mode 100644
index 000000000000..336720c4f07d
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.5.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+PEAR="${PV}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+DESCRIPTION="PEAR Base System"
+HOMEPAGE="http://pear.php.net/package/PEAR"
+SRC_URI="http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php:*[cli,pcre(+),xml,zlib]"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="dev-php/pear"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="${EPREFIX}/var/cache/pear"
+ [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="${EPREFIX}/var/tmp/pear"
+ [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="${EPREFIX}/tmp"
+
+ elog
+ elog "cache_dir is set to: ${PEAR_CACHEDIR}"
+ elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
+ elog "temp_dir is set to: ${PEAR_TEMPDIR}"
+ elog
+ elog "If you want to change the above values, you need to set"
+ elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
+ elog "accordingly in /etc/portage/make.conf and re-emerge ${PN}."
+ elog
+}
+
+src_prepare() {
+ cd PEAR-${PV}
+ epatch "${FILESDIR}/gentoo-libtool-mismatch-fix-v2.patch"
+ epatch_user
+}
+
+src_install() {
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ # install PEAR package
+ cd "${S}"/PEAR-${PEAR}
+
+ insinto /usr/share/php
+ doins -r PEAR/
+ doins -r OS/
+ doins PEAR.php PEAR5.php System.php
+ doins scripts/pearcmd.php
+ doins scripts/peclcmd.php
+
+ newbin scripts/pear.sh pear
+ newbin scripts/peardev.sh peardev
+ newbin scripts/pecl.sh pecl
+
+ # adjust some scripts for current version
+ for i in pearcmd.php peclcmd.php ; do
+ sed "s:@pear_version@:${PEAR}:g" -i "${D}/usr/share/php/${i}"
+ done
+
+ for i in pear peardev pecl ; do
+ sed "s:@bin_dir@:${EPREFIX}/usr/bin:g" -i "${D}/usr/bin/${i}"
+ sed "s:@php_dir@:${EPREFIX}/usr/share/php:g" -i "${D}/usr/bin/${i}"
+ done
+ sed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" -i "${D}/usr/bin/pear"
+
+ sed "s:@package_version@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Command/Package.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Dependency2.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v1.php"
+ sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v2.php"
+
+ # finalize install
+ insinto /etc
+ newins "${FILESDIR}"/pear.conf-r2 pear.conf
+ sed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" -i "${D}/etc/pear.conf"
+
+ # Change the paths for eprefix!
+ sed "s|s:19:\"/usr/share/php/docs\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/docs\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:19:\"/usr/share/php/data\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/data\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:20:\"/usr/share/php/tests\"|s:$(( ${#EPREFIX}+20 )):\"${EPREFIX}/usr/share/php/tests\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:14:\"/usr/share/php\"|s:$(( ${#EPREFIX}+14 )):\"${EPREFIX}/usr/share/php\"|g" -i "${D}/etc/pear.conf"
+ sed "s|s:8:\"/usr/bin\"|s:$(( ${#EPREFIX}+8 )):\"${EPREFIX}/usr/bin\"|g" -i "${D}/etc/pear.conf"
+
+ [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR#${EPREFIX}}"
+ keepdir "${PEAR_CACHEDIR#${EPREFIX}}"
+ diropts -m1777
+ keepdir "${PEAR_DOWNLOADDIR#${EPREFIX}}"
+}
+
+pkg_preinst() {
+ rm -f "${EROOT}/etc/pear.conf"
+}
diff --git a/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix-v2.patch b/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix-v2.patch
new file mode 100644
index 000000000000..0a7effe96fda
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix-v2.patch
@@ -0,0 +1,15 @@
+diff -aruN PEAR.orig/Builder.php PEAR/Builder.php
+--- PEAR.orig/Builder.php 2014-07-12 08:25:32.000000000 -0400
++++ PEAR/Builder.php 2015-01-16 13:43:14.927894013 -0500
+@@ -340,6 +340,11 @@
+ }
+ // }}} end of interactive part
+
++ if (file_exists('aclocal.m4')) {
++ $this->_runCommand('rm aclocal.m4');
++ $this->_runCommand('autoreconf');
++ }
++
+ // FIXME make configurable
+ if (!$user=getenv('USER')) {
+ $user='defaultuser';
diff --git a/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix.patch b/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix.patch
new file mode 100644
index 000000000000..53a33b833f7d
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/gentoo-libtool-mismatch-fix.patch
@@ -0,0 +1,31 @@
+Fixed libtool mismatch issues.
+Gentoo bug: 344605
+
+*** PEAR/Builder.php.old Mon Nov 8 16:22:52 2010
+--- PEAR/Builder.php Mon Nov 8 16:20:22 2010
+***************
+*** 326,331 ****
+--- 326,336 ----
+ }
+ // }}} end of interactive part
+
++ if (file_exists('aclocal.m4')) {
++ $this->_runCommand('rm aclocal.m4');
++ $this->_runCommand('autoreconf');
++ }
++
+ // FIXME make configurable
+ if(!$user=getenv('USER')){
+ $user='defaultuser';
+***************
+*** 471,474 ****
+ }
+ return PEAR_Common::log($level, $msg);
+ }
+! }
+\ No newline at end of file
+--- 476,479 ----
+ }
+ return PEAR_Common::log($level, $msg);
+ }
+! }
diff --git a/dev-php/PEAR-PEAR/files/pear.conf b/dev-php/PEAR-PEAR/files/pear.conf
new file mode 100644
index 000000000000..5a3c5298db6e
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/pear.conf
@@ -0,0 +1,2 @@
+#PEAR_Config 0.9
+a:7:{s:7:"doc_dir";s:19:"/usr/share/php/docs";s:8:"data_dir";s:19:"/usr/share/php/data";s:8:"test_dir";s:20:"/usr/share/php/tests";s:7:"php_dir";s:14:"/usr/share/php";s:7:"bin_dir";s:8:"/usr/bin";s:7:"php_bin";s:PHPCLILEN:"PHPCLI";s:9:"cache_dir";s:CACHEDIRLEN:"CACHEDIR";}
diff --git a/dev-php/PEAR-PEAR/files/pear.conf-r1 b/dev-php/PEAR-PEAR/files/pear.conf-r1
new file mode 100644
index 000000000000..78f69818940f
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/pear.conf-r1
@@ -0,0 +1,2 @@
+#PEAR_Config 0.9
+a:9:{s:7:"doc_dir";s:19:"/usr/share/php/docs";s:8:"data_dir";s:19:"/usr/share/php/data";s:8:"test_dir";s:20:"/usr/share/php/tests";s:7:"php_dir";s:14:"/usr/share/php";s:7:"bin_dir";s:8:"/usr/bin";s:7:"php_bin";s:PHPCLILEN:"PHPCLI";s:9:"cache_dir";s:CACHEDIRLEN:"CACHEDIR";s:12:"download_dir";s:DOWNLOADDIRLEN:"DOWNLOADDIR";s:8:"temp_dir";s:TEMPDIRLEN:"TEMPDIR";} \ No newline at end of file
diff --git a/dev-php/PEAR-PEAR/files/pear.conf-r2 b/dev-php/PEAR-PEAR/files/pear.conf-r2
new file mode 100644
index 000000000000..277227b4a47b
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/pear.conf-r2
@@ -0,0 +1,2 @@
+#PEAR_Config 0.9
+a:9:{s:7:"doc_dir";s:19:"/usr/share/php/docs";s:8:"data_dir";s:19:"/usr/share/php/data";s:8:"test_dir";s:20:"/usr/share/php/tests";s:7:"php_dir";s:14:"/usr/share/php";s:7:"bin_dir";s:8:"/usr/bin";s:7:"php_bin";s:12:"/usr/bin/php";s:9:"cache_dir";s:CACHEDIRLEN:"CACHEDIR";s:12:"download_dir";s:DOWNLOADDIRLEN:"DOWNLOADDIR";s:8:"temp_dir";s:TEMPDIRLEN:"TEMPDIR";}
diff --git a/dev-php/PEAR-PEAR/metadata.xml b/dev-php/PEAR-PEAR/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-PEAR/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>