summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-30 09:00:18 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-30 10:09:03 -0500
commit64c2197b18fdd111e59c7f5abac820ea40bf041c (patch)
tree6d6fd996d386e1754c171fb8b38534892e2ba265 /dev-php/pecl-http
parentdev-php/pecl-dbase: Remove masked version (diff)
downloadgentoo-64c2197b18fdd111e59c7f5abac820ea40bf041c.tar.gz
gentoo-64c2197b18fdd111e59c7f5abac820ea40bf041c.tar.bz2
gentoo-64c2197b18fdd111e59c7f5abac820ea40bf041c.zip
dev-php/pecl-http: Remove masked versions
Bug: https://bugs.gentoo.org/651784 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0-r1.ebuild69
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild72
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0.ebuild57
4 files changed, 0 insertions, 199 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index bf0b8fdd6cfb..ae6d032c2f23 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,3 +1,2 @@
-DIST pecl_http-2.6.0.tgz 217673 BLAKE2B a7147924cfc018c3e273d85666d9792ea614955d0aa20ac43171266d91d139dccdbf2472dec4d145b798ce99a541dba48f7bed6009fbdf2a7ad81ab322963788 SHA512 12d18049411a4133008449a1e7458a3055322dc337f421e0e2be126ec965f15b0189af6fccd9ca4537c48819c763b9e020906ac6d09d87ead92f4436fac595ad
DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850bdc356d27a6e1d1097a8e2cfc61963a1daccd1d0f269a7cef5b243d45cdfaff5138321fe20df615dde44d19e3 SHA512 e67d4b32ba6f524e3fcf65f5497b94275e1a4a14fce97c57afe366369f368b3acdbedf364ed73cf983fb2c5f57f498adaa1100e7c936f11cbc5de1caedad7b51
DIST pecl_http-3.2.3.tgz 220204 BLAKE2B 2a712dc8f69a8a80f6f8c306883df580fdff4a0d4cb0ac06cc004f8622b30b8e2f5d373276381fd3ad67657a80cc929be81745f200a98b6ed5e475de5639dfc5 SHA512 e955e3246db9a9172081dd9a077154139c585bfce546e91839052bbab4d0db9d0695122574a66891ceba5c0b7e8a8f0768274e1516521ccb95cd19504dc13666
diff --git a/dev-php/pecl-http/pecl-http-2.6.0-r1.ebuild b/dev-php/pecl-http/pecl-http-2.6.0-r1.ebuild
deleted file mode 100644
index 17aa145af9e9..000000000000
--- a/dev-php/pecl-http/pecl-http-2.6.0-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="2"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="php_targets_php5-6? (
- dev-libs/libevent
- dev-php/pecl-propro:0[php_targets_php5-6]
- dev-php/pecl-raphf:0[php_targets_php5-6]
- net-dns/libidn
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- dev-lang/php:5.6[hash,session,iconv] )"
-RDEPEND="${DEPEND}"
-PDEPEND="
- php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
- php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
-
-src_prepare() {
- if use php_targets_php5-6 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php5-6 ; then
- php-ext-pecl-r3_src_install
-
- # Ensure that the http extension is loaded after its
- # dependencies raphf and propro (bug 612054). Some day
- # this should be possible through the eclass (bug 586446).
- local slot, file, oldname, newname
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- for file in $(php_slot_ini_files "${slot}") ; do
- # Prepend "zz" to the ini symlink name. This is sadly
- # coupled to the naming convention in the eclass.
- oldname="${ED}/${file/ext/ext-active}"
- newname="${oldname/${PHP_EXT_NAME}.ini/zz${PHP_EXT_NAME}.ini}"
- mv "${oldname}" "${newname}" \
- || die "failed to rename ${oldname} to ${newname}"
- einfo "renamed ${oldname} to ${newname}"
- done
- done
- fi
-}
diff --git a/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild b/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
deleted file mode 100644
index 63cfe3ff8054..000000000000
--- a/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="2"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="php_targets_php5-6? (
- dev-libs/libevent
- dev-php/pecl-propro:0[php_targets_php5-6]
- dev-php/pecl-raphf:0[php_targets_php5-6]
- net-dns/libidn
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- dev-lang/php:5.6[hash,session,iconv] )"
-RDEPEND="${DEPEND}"
-PDEPEND="
- php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
- php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )
- php_targets_php7-2? ( dev-php/pecl-http:7[php_targets_php7-2] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
-
-src_prepare() {
- if use php_targets_php5-6 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php5-6 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
- Makefile || die
- NO_INTERACTION="yes" emake test
- rm modules/propro.so modules/raphf.so || die
- done
-}
-
-pkg_postinst() {
- ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
- ewarn "Please review the documentation and update your code."
-}
diff --git a/dev-php/pecl-http/pecl-http-2.6.0.ebuild b/dev-php/pecl-http/pecl-http-2.6.0.ebuild
deleted file mode 100644
index 2cb44cf7081a..000000000000
--- a/dev-php/pecl-http/pecl-http-2.6.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="2"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="php_targets_php5-6? (
- dev-libs/libevent
- dev-php/pecl-propro:0[php_targets_php5-6]
- dev-php/pecl-raphf:0[php_targets_php5-6]
- net-dns/libidn
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- dev-lang/php:5.6[hash,session,iconv] )"
-RDEPEND="${DEPEND}"
-PDEPEND="
- php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
- php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
-
-src_prepare() {
- if use php_targets_php5-6 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php5-6 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-pkg_postinst() {
- ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
- ewarn "Please review the documentation and update your code."
-}