summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-01-23 13:15:59 -0500
committerBrian Evans <grknight@gentoo.org>2020-01-23 13:38:49 -0500
commitc7403c3a563edf2d17dc1c3d1594df3fa60b69ab (patch)
tree06d59f7befd2e86a5eda66f3ebfaa3609c108e8b /dev-php/pecl-oauth
parentdev-php/pecl-ssh2: Drop unsupported slots from live build (diff)
downloadgentoo-c7403c3a563edf2d17dc1c3d1594df3fa60b69ab.tar.gz
gentoo-c7403c3a563edf2d17dc1c3d1594df3fa60b69ab.tar.bz2
gentoo-c7403c3a563edf2d17dc1c3d1594df3fa60b69ab.zip
dev-php/pecl-oauth: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-oauth')
-rw-r--r--dev-php/pecl-oauth/Manifest2
-rw-r--r--dev-php/pecl-oauth/files/2.0.2-compare_segfault.patch48
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild56
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.3.ebuild59
4 files changed, 0 insertions, 165 deletions
diff --git a/dev-php/pecl-oauth/Manifest b/dev-php/pecl-oauth/Manifest
index a674f719edc2..baeb7747bce1 100644
--- a/dev-php/pecl-oauth/Manifest
+++ b/dev-php/pecl-oauth/Manifest
@@ -1,3 +1 @@
-DIST oauth-2.0.2.tgz 49115 BLAKE2B 292c8c2d7fa3728aa6a73cdb65ee1c603f341cd24596d64b910f495ef649adb1f90ba4dfdab5ce1802dee9e8a0e3a6af502da340ed467de6e8c5d83df18abc7d SHA512 b7aa9459542ec390a5420127d75607702ae6df6254f4e39acb62d35c6a39b8b7990499c279df07ce681081e455b55219c51df42fd516321f317465badf6d459d
-DIST oauth-2.0.3.tgz 49413 BLAKE2B 581ba50a3add230364ed5c161b76073b1dd7c301eaf4cd048ed97039deb45fea73da56f0d0b69186d8f6fb20a55724ba5892d80bd7aae343b15534d3c82b6346 SHA512 3e0ce5ce01533bfd304c0c34465cc184fbd0af1a25f5192860e6394c86dc948688cc8d4b419b48676481cef3a685ba70ac612a8c516da26d0dfe9efdef7e98d9
DIST oauth-2.0.4.tgz 49359 BLAKE2B d5fb23293fc03f40e2b3a5c5ad51bce1b06a6004e1f20d1563b3db7bb79a71f70bca467348d68b4f6d2393003b4ad23debbe5877192d9e189056e86f9fc00b3e SHA512 269b579f87a9f3f229433c74937f74b9b6df453a6e05f7751ca12fa5f24c9ad62d1ebe5cdb370d33d774a0f2e244c1c685a53226dcb35c0005b5532a00c137d4
diff --git a/dev-php/pecl-oauth/files/2.0.2-compare_segfault.patch b/dev-php/pecl-oauth/files/2.0.2-compare_segfault.patch
deleted file mode 100644
index f0b8d7ae216f..000000000000
--- a/dev-php/pecl-oauth/files/2.0.2-compare_segfault.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From f1a5b6dea1982dab03c810edd321ca57907d41fe Mon Sep 17 00:00:00 2001
-From: Adam Saponara <as@php.net>
-Date: Fri, 24 Feb 2017 17:20:51 -0500
-Subject: [PATCH] Fix bug #74163: Segfault in oauth_compare_value
-
-Credit to @russpos for finding this bug
----
- oauth.c | 4 ++--
- tests/oauth_sbs.phpt | 4 ++++
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/oauth.c b/oauth.c
-index 62522bd..198e2cb 100644
---- a/oauth.c
-+++ b/oauth.c
-@@ -374,8 +374,8 @@ static int oauth_strcmp(zval *first, zval *second)
- static int oauth_compare_value(const void *a, const void *b)
- {
- Bucket *f, *s;
-- f = *(Bucket **)a;
-- s = *(Bucket **)b;
-+ f = (Bucket *)a;
-+ s = (Bucket *)b;
-
- return oauth_strcmp(&f->val, &s->val);
- }
-diff --git a/tests/oauth_sbs.phpt b/tests/oauth_sbs.phpt
-index a49d2b4..4e9269e 100644
---- a/tests/oauth_sbs.phpt
-+++ b/tests/oauth_sbs.phpt
-@@ -21,6 +21,8 @@ echo "-- putting oauth_signature inside by mistake --\n";
- echo oauth_get_sbs('GET', 'http://127.0.0.1:12342/',array('oauth_signature'=>'hello world')),"\n";
- echo "-- merging url query and extra params --\n";
- echo oauth_get_sbs('GET', 'http://127.0.0.1:12342/script?arg1=1',array('arg2' => '2')),"\n";
-+echo "-- with array value --\n";
-+echo oauth_get_sbs('GET', 'http://127.0.0.1:12342/script',array('arg2' => [1, 2, 3])),"\n";
-
- ?>
- --EXPECTF--
-@@ -44,3 +46,5 @@ GET&http%3A%2F%2F127.0.0.1%3A12342%2F&test%3D
- GET&http%3A%2F%2F127.0.0.1%3A12342%2F&
- -- merging url query and extra params --
- GET&http%3A%2F%2F127.0.0.1%3A12342%2Fscript&arg1%3D1%26arg2%3D2
-+-- with array value --
-+GET&http%3A%2F%2F127.0.0.1%3A12342%2Fscript&arg2%3D1%26arg2%3D2%26arg2%3D3
---
-2.1.4
-
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild
deleted file mode 100644
index 987a87b85ee0..000000000000
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PHP_EXT_NAME="oauth"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
-
-inherit php-ext-pecl-r3
-
-# Really only build for 7.0
-USE_PHP="php7-0 php7-1 php7-2"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
-LICENSE="BSD"
-SLOT="7"
-IUSE="+curl examples"
-
-DEPEND="php_targets_php7-0? ( dev-lang/php:7.0[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-1? ( dev-lang/php:7.1[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-2? ( dev-lang/php:7.2[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6(-)?] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
- local PATCHES=( "${FILESDIR}/${PV}-compare_segfault.patch" )
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-oauth
- $(use_with curl)
- )
-
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
- php-ext-pecl-r3_src_install
- fi
-}
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.3.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.3.ebuild
deleted file mode 100644
index 13247d2fb7c7..000000000000
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PHP_EXT_NAME="oauth"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-# Really only build for 7.0
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
-LICENSE="BSD"
-SLOT="7"
-IUSE="+curl examples"
-
-DEPEND="php_targets_php7-0? ( dev-lang/php:7.0[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-1? ( dev-lang/php:7.1[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-2? ( dev-lang/php:7.2[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-3? ( dev-lang/php:7.3[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6(-)?] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- # Disable tests that depend on header order
- rm "${S}/tests/bug16946.phpt" "${S}/tests/overflow_redir.phpt" || die
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-oauth
- $(use_with curl)
- )
-
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- php-ext-pecl-r3_src_install
- fi
-}