summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:45:17 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:47:54 +0100
commitc69513d912f518d237f7b34aa66b50cedf2384c6 (patch)
tree7a8e9382641ff37974ba52ac8e32093129b8f21a /dev-php/pecl-ssh2
parentdev-php/pecl-http: add PHP 7.4 support (diff)
downloadgentoo-c69513d912f518d237f7b34aa66b50cedf2384c6.tar.gz
gentoo-c69513d912f518d237f7b34aa66b50cedf2384c6.tar.bz2
gentoo-c69513d912f518d237f7b34aa66b50cedf2384c6.zip
dev-php/pecl-ssh2: add PHP 7.4 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-ssh2')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild6
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
index 72ef46fdff15..583c2bfcf037 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
@@ -5,12 +5,12 @@ EAPI="7"
PHP_EXT_NAME="ssh2"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
inherit php-ext-source-r3 git-r3
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
DESCRIPTION="PHP bindings for the libssh2 library"
LICENSE="PHP-3.01"
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
HOMEPAGE="https://pecl.php.net/package/ssh2"
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
index 72ef46fdff15..583c2bfcf037 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -5,12 +5,12 @@ EAPI="7"
PHP_EXT_NAME="ssh2"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
inherit php-ext-source-r3 git-r3
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
DESCRIPTION="PHP bindings for the libssh2 library"
LICENSE="PHP-3.01"
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
HOMEPAGE="https://pecl.php.net/package/ssh2"
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare