summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:19:17 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:21:22 -0500
commitc2eb2b6bf3ecf37da5c9b628855a81e8900a3dd1 (patch)
tree5269bc2a0972b885374aeef423ff99c12e985c37 /dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
parentdev-php/sebastian-recursion-context: New package for an unbundled phpunit (diff)
downloadgentoo-c2eb2b6bf3ecf37da5c9b628855a81e8900a3dd1.tar.gz
gentoo-c2eb2b6bf3ecf37da5c9b628855a81e8900a3dd1.tar.bz2
gentoo-c2eb2b6bf3ecf37da5c9b628855a81e8900a3dd1.zip
dev-php/sebastian-object-enumerator: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild')
-rw-r--r--dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild b/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
new file mode 100644
index 000000000000..db03da9b2606
--- /dev/null
+++ b/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Traverses array structures and object graphs to enumerate all referenced objects"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/sebastian-recursion-context-3.0
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/ObjectEnumerator
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}