summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:02:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:32:59 +0200
commit7cb41b34c9675760dc115e85a53b6ad48f843f64 (patch)
tree2bcdbb183bd30130d58cf624093fd01bd0cb4860 /dev-php
parentdev-php/xhprof: bump to v2.3.5 (diff)
downloadgentoo-7cb41b34c9675760dc115e85a53b6ad48f843f64.tar.gz
gentoo-7cb41b34c9675760dc115e85a53b6ad48f843f64.tar.bz2
gentoo-7cb41b34c9675760dc115e85a53b6ad48f843f64.zip
dev-php/xdebug: bump to v3.1.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/xdebug-3.1.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index 5f70b3b24e97..d8630504841f 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -3,3 +3,4 @@ DIST xdebug-2.9.8.tar.gz 438295 BLAKE2B 8645052faceb354817ddb448f46af5b849507d31
DIST xdebug-3.0.2.tar.gz 435761 BLAKE2B 0476d29b3a960d83fd0818098a3d076f48f4d67057a2b6ec79571b011a9f364b18d3319771ad18e7145aa0f0f45fab7ed13d814b863731abe1721aafa8b59408 SHA512 723e00885a49a5626870cc4cb0f7fd49a3173c8d4e9b4022009430fdeaa1b152828de18e6e7fa709be8bb11989c89dc2d9940de9cc3d592174b5dafbc3d2c52d
DIST xdebug-3.0.3.tar.gz 437261 BLAKE2B 7ccfa8acbbe8b40eb086c9d4f47d363ec52850f5b0b91480bebfa416d7b88edf20deb6ee5fb5514dd1885f7a5b77c4b18caecf958d7dcf463c44c259d0fe2b89 SHA512 2ea5c6e2d6481aeeb5b2d8e39f5c5686d9b7480aea0c159f3da6e830700594b24129c1c4242ff8413b52aa2ed0ea872bf72a17fe23facb69c1cae75a917bde5d
DIST xdebug-3.0.4.tar.gz 438559 BLAKE2B 0b4dc4a014f2459691bf43bb76d70a4080a6191b5f6cf4998751e73cdfcbecb7a6274e6f398476a2c68d014ddb25662e08e45b68fbc73c9b38c79c94b0682124 SHA512 f7f935903adb18f0920c919c3e5c923b70667dd82772bef7ae73fe40441ad1cb73f030aa206046720d4bfcf8b33f56d454cbb5f65dbdc275b7c1fd1907ff4ddb
+DIST xdebug-3.1.1.tar.gz 468120 BLAKE2B 038774612158c2c9b406e29dd70e2a3e182ce121bc92036eeb3362be0ba513a223cb2da41bdfe914d6861ae9d94ff33c5301cc23725ee771f47876c8095ae0b8 SHA512 b91bca3bac184723b3f6dc0c5db012f2ec0895ed55cd4ff83f73d35462b9cea654476c848f7d61559a4bd8661ce335fc71a45a7cab1165f4197d265e31eccc71
diff --git a/dev-php/xdebug/xdebug-3.1.1.ebuild b/dev-php/xdebug/xdebug-3.1.1.ebuild
new file mode 100644
index 000000000000..00bf4b8a058b
--- /dev/null
+++ b/dev-php/xdebug/xdebug-3.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="3.0-xdebug.ini"
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+PHP_EXT_NEEDED_USE="-threads(-)"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+# Tests are known to fail
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ TEST_PHP_CGI_EXECUTABLE="${PHPCGI}" \
+ TEST_PHPDBG_EXECUTABLE="${PHPCLI}dbg" \
+ "${PHPCLI}" run-xdebug-tests.php
+ done
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.mode to off, as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.mode to one or more modes e.g. develop,debug,trace"
+ elog ""
+ elog "The 3.0 major release changes many options."
+ elog "Review https://xdebug.org/docs/upgrade_guide for differences from 2.x"
+}