summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-19 07:45:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-19 07:45:55 +0200
commit18cbcff1ecdd6984209f5510fd1bef49eaa9d60b (patch)
treed0f35389baa152a58d54b4a82125dc1426d384d3 /dev-python/Faker/Faker-8.2.0.ebuild
parentdev-python/markupsafe: Bump to 2.0.1 (diff)
downloadgentoo-18cbcff1ecdd6984209f5510fd1bef49eaa9d60b.tar.gz
gentoo-18cbcff1ecdd6984209f5510fd1bef49eaa9d60b.tar.bz2
gentoo-18cbcff1ecdd6984209f5510fd1bef49eaa9d60b.zip
dev-python/Faker: Bump to 8.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker/Faker-8.2.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-8.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.2.0.ebuild b/dev-python/Faker/Faker-8.2.0.ebuild
new file mode 100644
index 000000000000..0b94b1e3251f
--- /dev/null
+++ b/dev-python/Faker/Faker-8.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest