summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:12:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:17 +0100
commit779f041cf42ead0527bbd9286875744b89b2ee50 (patch)
tree68642e0ec88a8ba6fbaca1dbd077308d94a0235d /dev-python/Faker
parentdev-python/imageio-ffmpeg: Bump to 0.4.8 (diff)
downloadgentoo-779f041cf42ead0527bbd9286875744b89b2ee50.tar.gz
gentoo-779f041cf42ead0527bbd9286875744b89b2ee50.tar.bz2
gentoo-779f041cf42ead0527bbd9286875744b89b2ee50.zip
dev-python/Faker: Bump to 16.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-16.1.0.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-16.1.0.ebuild b/dev-python/Faker/Faker-16.1.0.ebuild
new file mode 100644
index 000000000000..ab4075c0d00b
--- /dev/null
+++ b/dev-python/Faker/Faker-16.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 4a8834b53d83..de79d336d8d2 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-15.3.4.tar.gz 1599191 BLAKE2B 8fc26d35cbcde467123c8a5e15813351e65cf81a3640552115bdc55dff48b123e28b180e46595b80029dfdc0d3545b9e75b3f8c2deff380a6168aa2ab603ef2f SHA512 f9c50008c492a2aa8a7d7e62d0f404036cc9161baa3036f5948f607d4e971b34945401f565b3640eca71e7716fa5f2f3d82dd029f84f35dd4925e647638c0c56
+DIST Faker-16.1.0.tar.gz 1599748 BLAKE2B 62c55659b84e556ad2960b0b3c3e49fc96beca86850469af152c833f5b8680e222ef8bde7dbeacb75ac13535ed9ec0774f5c524d58f10d92c78542ec4714ff1f SHA512 7da4ca3824b64fa1b36d5a3f58206e03f61ca984a672e59e68e8ab642da6bb08d7656dc2422a7107ee46ca2d5a0ec5bc7ed4301c296a07f2dfc39c2cfb6ff693