summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-21 07:20:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-21 08:06:46 +0200
commitf21aa999d807df33df2aa8eb6a1997c3df9a2093 (patch)
tree39059c16500136b4b08b993e5b382466291fd9dd /dev-python/Faker
parentdev-python/dask: Bump to 2023.7.1 (diff)
downloadgentoo-f21aa999d807df33df2aa8eb6a1997c3df9a2093.tar.gz
gentoo-f21aa999d807df33df2aa8eb6a1997c3df9a2093.tar.bz2
gentoo-f21aa999d807df33df2aa8eb6a1997c3df9a2093.zip
dev-python/Faker: Bump to 19.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-19.2.0.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-19.2.0.ebuild b/dev-python/Faker/Faker-19.2.0.ebuild
new file mode 100644
index 000000000000..48c456a2d7b5
--- /dev/null
+++ b/dev-python/Faker/Faker-19.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index c4e4adcc9f94..b29d182ceeb0 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -2,3 +2,4 @@ DIST Faker-18.11.2.tar.gz 1670644 BLAKE2B 0496e9d2169932fd158b8eb62693d1c7f833c0
DIST Faker-18.13.0.tar.gz 1672316 BLAKE2B c7b3a040276508c8d08c184e90dfd054d62ef635299e637476fedf0d3e01d0e311bd855c4df39dd449244c07c71a1fe216063c07a3abef69f8ec8fa967124769 SHA512 b5cd907d962f39d15001d0218993dd6b4f65ac6252fcb1c72bbb2905a585ad26d0f7c6807cef43b41ce430122fe4730d26f57f119bc3547a432d133e87d98beb
DIST Faker-19.0.0.tar.gz 1673020 BLAKE2B f3be24f29eb870535034afdecd57d0172b8cbc4f9228796373eab9f5be3211d39134d94f9c3543a0387579a5ed7d0434b9eede12b824b93652ee4b2d964f5835 SHA512 fdc3d0618dae04fa1f4fc3ce8d10a353d8272059c557729e93891e59c85b0c03e11009febfd5d500ab5425b6ba4446c9df72f84bc1f632c0cec76a761bd8c9f2
DIST Faker-19.1.0.tar.gz 1673101 BLAKE2B 92349e38c72fc85fcb0711555645ca3745015df485ba3e366000e71d620f14bad18b1b26fe5e456e18269ba867daf0ba42779623afbc96e5f64fb0537c842d9b SHA512 4fa11f479e78ac4835f00f17ce99aebf17d88e626548094f122dccb78f6caddde8cd058f33f2dc304725049e75e9f1c42b549ff139ed0d9d798bbb630bb1e80a
+DIST Faker-19.2.0.tar.gz 1676517 BLAKE2B f9204266add7bf042c3993196474aeb633986932ee8ab2e83985a88e5e5639219efbadcf54c2359ada4c118744fb0d4af858a4bf70a957f467599dcd2bbfac7a SHA512 96c5b1c02faef86e924ecca68d734f51e41da9e1f9e1f0ca1634b289717ff2af5596e4b713352047156d8478ae80006dc98897b48c8b20ce0e210e65c7dcb81d