summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-05-16 15:11:26 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-05-16 15:12:16 +0200
commit64880ae8d7216b71a95c692b0e0f62d75592d096 (patch)
tree0e79141e0ac78f4134a9b5bf5f3722c7f83ed2e8 /dev-python/PeachPy
parentdev-python/vpython: Remove old (diff)
downloadgentoo-64880ae8d7216b71a95c692b0e0f62d75592d096.tar.gz
gentoo-64880ae8d7216b71a95c692b0e0f62d75592d096.tar.bz2
gentoo-64880ae8d7216b71a95c692b0e0f62d75592d096.zip
dev-python/PeachPy: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/PeachPy')
-rw-r--r--dev-python/PeachPy/Manifest1
-rw-r--r--dev-python/PeachPy/PeachPy-2021.10.13.ebuild31
-rw-r--r--dev-python/PeachPy/files/PeachPy-2021.10.13-gentoo.patch11
-rw-r--r--dev-python/PeachPy/metadata.xml11
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/PeachPy/Manifest b/dev-python/PeachPy/Manifest
new file mode 100644
index 000000000000..29f4dbf6b889
--- /dev/null
+++ b/dev-python/PeachPy/Manifest
@@ -0,0 +1 @@
+DIST PeachPy-2021.10.13.tar.gz 248855 BLAKE2B 5f8e7845dfa7327c62e6a953505260645ca29dc762dcb3ffd971a6a07c81f259776286c12c2147e980ae43f77d3ce060a87201e2189123290845f6543c74775f SHA512 c6370de8da9152e812702a3bb53592cba89ee24fdfbeaa87d49374bad7b2d79c60e54bac17a29d861f5881f4ce076f2fe96bff378ef31bdf3cbc6bc5093f6f3d
diff --git a/dev-python/PeachPy/PeachPy-2021.10.13.ebuild b/dev-python/PeachPy/PeachPy-2021.10.13.ebuild
new file mode 100644
index 000000000000..5e09b4102df9
--- /dev/null
+++ b/dev-python/PeachPy/PeachPy-2021.10.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+CommitId=257881e0a7ce985c1cf96653db1264bf09adf510
+
+DESCRIPTION="Portable Efficient Assembly Code-generator in Higher-level Python"
+HOMEPAGE="https://pypi.org/project/PeachPy/"
+SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # depends on an old version of werkzeug
+
+RDEPEND="
+ dev-python/Opcodes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
diff --git a/dev-python/PeachPy/files/PeachPy-2021.10.13-gentoo.patch b/dev-python/PeachPy/files/PeachPy-2021.10.13-gentoo.patch
new file mode 100644
index 000000000000..c5ecab041a76
--- /dev/null
+++ b/dev-python/PeachPy/files/PeachPy-2021.10.13-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2022-05-15 19:33:42.938456878 +0200
++++ b/setup.py 2022-05-15 19:33:57.869231488 +0200
+@@ -35,7 +35,7 @@
+ def run(self):
+ # package_dir may be None, in that case use the current directory.
+ import os
+- if self.distribution.package_dir is None:
++ if not self.distribution.package_dir:
+ src_dir = os.getcwd()
+ else:
+ src_dir = os.path.abspath(self.distribution.package_dir[""])
diff --git a/dev-python/PeachPy/metadata.xml b/dev-python/PeachPy/metadata.xml
new file mode 100644
index 000000000000..c7def3ba0623
--- /dev/null
+++ b/dev-python/PeachPy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Maratyszcza/PeachPy</remote-id>
+ </upstream>
+</pkgmetadata>