summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-07-03 11:56:55 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-07-03 14:18:10 -0700
commit918a6a984812b3f2689813f22b48bed9f0af4a75 (patch)
tree14b8d5330163aade8a659a923c55be0bab6ce3f6 /dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild
parentsys-kernel/aufs-sources: Bump to latest aufs, genpatches and linux release (diff)
downloadgentoo-918a6a984812b3f2689813f22b48bed9f0af4a75.tar.gz
gentoo-918a6a984812b3f2689813f22b48bed9f0af4a75.tar.bz2
gentoo-918a6a984812b3f2689813f22b48bed9f0af4a75.zip
dev-python/SaltTesting: Version bump to 2018.1.16
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild')
-rw-r--r--dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild b/dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild
new file mode 100644
index 000000000000..644e5b6771e0
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2018.1.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="https://saltstack.com/community/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"