summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-09 15:41:34 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-09 16:10:02 +0100
commite22cfaf0dcba00a7ce9421ef1b445cd96bd6e02d (patch)
tree7d35335e980279d81da4a49fde8506fc720247be /dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild
parentapp-dicts/myspell-en: version bump (diff)
downloadgentoo-e22cfaf0dcba00a7ce9421ef1b445cd96bd6e02d.tar.gz
gentoo-e22cfaf0dcba00a7ce9421ef1b445cd96bd6e02d.tar.bz2
gentoo-e22cfaf0dcba00a7ce9421ef1b445cd96bd6e02d.zip
dev-python/abstract_rendering: New package, ebuild written by me
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild')
-rw-r--r--dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild b/dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild
new file mode 100644
index 000000000000..0733e9b50b25
--- /dev/null
+++ b/dev-python/abstract_rendering/abstract_rendering-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rendering as a binning process"
+HOMEPAGE="
+ https://github.com/JosephCottam/AbstractRendering
+ http://pypi.python.org/pypi/abstract_rendering
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed \
+ -e 's:"-O3",::g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}