summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/aioeventlet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/aioeventlet')
-rw-r--r--dev-python/aioeventlet/Manifest1
-rw-r--r--dev-python/aioeventlet/aioeventlet-0.4.ebuild24
-rw-r--r--dev-python/aioeventlet/metadata.xml16
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aioeventlet/Manifest b/dev-python/aioeventlet/Manifest
new file mode 100644
index 000000000000..dfc7df906bfd
--- /dev/null
+++ b/dev-python/aioeventlet/Manifest
@@ -0,0 +1 @@
+DIST aioeventlet-0.4.tar.gz 64314 SHA256 fe78c2b227ce077b1581e2ae2c071f351111d0878ec1b0216435f6a898df79a6 SHA512 6d76bacd1ccaf477f121bf57f2963d37c86208547beb5fe7d2c8dc22d787d7ed98761869d3957b9c1f62dc40ca462363f4a7cb2a80b6dabf13f89950d314c2ce WHIRLPOOL 4be9753fb9d2784ffd7e1590d0cebb5a9163d9fa178d5cf3537bf1c297d0e64eb921172af5d50c9cf9ada62ec77be6adbd74679f0aa429cfdba5eb193aeb87c1
diff --git a/dev-python/aioeventlet/aioeventlet-0.4.ebuild b/dev-python/aioeventlet/aioeventlet-0.4.ebuild
new file mode 100644
index 000000000000..62160f3bb179
--- /dev/null
+++ b/dev-python/aioeventlet/aioeventlet-0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio event loop scheduling callbacks in eventlet"
+HOMEPAGE="http://pypi.python.org/pypi/aioeventlet https://bitbucket.org/haypo/aioeventlet"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/asyncio-0.4.1[${PYTHON_USEDEP}]' 'python3_3')
+ $(python_gen_cond_dep '>=dev-python/trollius-0.3[${PYTHON_USEDEP}]' 'python2_7')"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/aioeventlet/metadata.xml b/dev-python/aioeventlet/metadata.xml
new file mode 100644
index 000000000000..595605a0ea16
--- /dev/null
+++ b/dev-python/aioeventlet/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+aioeventlet implements the asyncio API (PEP 3156) on top of eventlet. It makes possible to write asyncio code in a project currently written for eventlet.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">aioeventlet</remote-id>
+ <remote-id type="bitbucket">haypo/aioeventlet</remote-id>
+ </upstream>
+</pkgmetadata>