summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-06-28 19:32:09 -0400
committerAaron Bauman <bman@gentoo.org>2017-07-09 20:16:38 -0400
commitb47d6bfadce218089f726137ae72c1b623291cba (patch)
tree8f32b0b2422739de266097692b601a671fe9ad99 /dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
parentdev-python/aiohttp: add 1.3.5 for net-misc/gns3-server dependency (diff)
downloadgentoo-b47d6bfadce218089f726137ae72c1b623291cba.tar.gz
gentoo-b47d6bfadce218089f726137ae72c1b623291cba.tar.bz2
gentoo-b47d6bfadce218089f726137ae72c1b623291cba.zip
dev-python/aiohttp-cors: add 0.5.1 for net-misc/gns3-server dependency
Closes: https://github.com/gentoo/gentoo/pull/5007
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
new file mode 100644
index 000000000000..f0c5fa8cee4e
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}