summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 04:25:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 04:40:52 +0200
commitbc869266d2dfd279a3773f462b6774e6d367e091 (patch)
tree3dc59803ded7691f05019761e287b3ae65828682 /dev-python/ansible-compat
parentdev-python/stripe: Bump to 6.3.0 (diff)
downloadgentoo-bc869266d2dfd279a3773f462b6774e6d367e091.tar.gz
gentoo-bc869266d2dfd279a3773f462b6774e6d367e091.tar.bz2
gentoo-bc869266d2dfd279a3773f462b6774e6d367e091.zip
dev-python/ansible-compat: Bump to 4.1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.9.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index db2b79d89be2..783f6953834c 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,4 @@
DIST ansible-compat-4.1.5.tar.gz 68562 BLAKE2B b28b6e5185b29a55d452e9c72636b31a1a35c68f207cc07376fafd0a70335966d06f927a803582b715b29c090a80aa5aa2663cba54221cb4d2dbcd9a11ec5a7a SHA512 6da0bab56237a6447462ed9ef528711eb4c998de2732ec021e8257d2baf6cbb1e1435707440b4c0d122fb4f938c855693bcd555e147613f230105e3af74c00a6
DIST ansible-compat-4.1.7.tar.gz 69900 BLAKE2B c8549573d4a4325579b6026b6b5fad5fe0abb0fdcf07a4c8e0699c040a97409632202f0a38703a113f9a86f68328642d8d5c4b897e3601a13737bc2a4deb4d88 SHA512 b3175573113a3df37923e582c191dd5f4522c3a2171cc93b186e49d5ca6baa2fd8b2e7af2e9457bb21b5bd6df6c9f82fccc10b5e2bfeda84c890c4cbc37fafb4
DIST ansible-compat-4.1.8.tar.gz 71895 BLAKE2B 19a3cdc953e678a82f6b187ca224c9f10eccf36f57aba2305bf00bc7b3606dfc2caddef7331cd920ae67731b904bc21b1af19fb0945625b050162e0edc8ab652 SHA512 0b9157fd60e1ae9b26c103118fad3e8e28f872c7093d0c6238b047072ac3232e7f9a4c50001125850f4bdd0ba06a1efd8df44a994b1dfaaf7d3f3cb2cb888524
+DIST ansible-compat-4.1.9.tar.gz 72116 BLAKE2B d8ada9162b30526c85cb8ab2f365ce85800e2d5c513acdb665a8474cdb666cc508ecf412379bb95a0c9c525d7d0432d2907701bbcaa68c2da3c764de9ae3c3eb SHA512 5d7177889f5e1acec27585980d0df15f6ea37f816da2438e200ce9450ff287f282a8abd66caab238c810decf9163a0e52f0c9bf2a03b1f885e6a58da20f7103a
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.9.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.9.ebuild
new file mode 100644
index 000000000000..6a1d0e51abeb
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+)
+
+distutils_enable_tests pytest