summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-22 07:03:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 07:03:08 +0200
commitd0c6710c9a3413c97fb1f7142783a2674e7bc881 (patch)
treeba8ed067edf67610424be880f0cf2afdba6a66c2 /dev-python/ansible-compat
parentdev-python/immutabledict: Bump to 3.0.0 (diff)
downloadgentoo-d0c6710c9a3413c97fb1f7142783a2674e7bc881.tar.gz
gentoo-d0c6710c9a3413c97fb1f7142783a2674e7bc881.tar.bz2
gentoo-d0c6710c9a3413c97fb1f7142783a2674e7bc881.zip
dev-python/ansible-compat: Bump to 4.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index eb660108cc36..43c8999f270c 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,2 +1,3 @@
DIST ansible-compat-3.0.2.tar.gz 63328 BLAKE2B d09ae255e08531b26f8cac7082a3ad0cc24f3772b7769b75d644a846dcc1ec0ff65fe1a7e351eeecadd70caae5ef5b5146396df5ec586e10296e116310333e6b SHA512 79f20a25b25104f4f90a4d52317bd01ceb07c00c69dc2e61b74b4c7448805bd966d001893ccf7530bec819ae9ead2515ae70219a887fda733344245cc025dfeb
DIST ansible-compat-4.1.2.tar.gz 66934 BLAKE2B 08d17ce6f83b2ac2fc08fab1b3ef54742e75eb0236792fdcf2791a521bc154184d92f6d1f25b241ac6c524352f9cd39be8d3c74d414625a315a468aeb8ce09a8 SHA512 ef6ad4daf7c565de5b1ef1a5ad204e2b8c938f81ef0a736a1af660836ee557d5c88fc06eced2a8a9fb0c6ac5b48cda243052d5ae0b0f634653c9d41211739e64
+DIST ansible-compat-4.1.5.tar.gz 68562 BLAKE2B b28b6e5185b29a55d452e9c72636b31a1a35c68f207cc07376fafd0a70335966d06f927a803582b715b29c090a80aa5aa2663cba54221cb4d2dbcd9a11ec5a7a SHA512 6da0bab56237a6447462ed9ef528711eb4c998de2732ec021e8257d2baf6cbb1e1435707440b4c0d122fb4f938c855693bcd555e147613f230105e3af74c00a6
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.5.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.5.ebuild
new file mode 100644
index 000000000000..04974cd8fbc4
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest