summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-26 03:30:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-26 03:30:15 +0200
commit1078ef45ca2fb9833e9398fcd4eea37fb37626fa (patch)
tree8e35f4f54bff07547b5efa72482239db53878078 /dev-python/apprise
parentdev-python/mrcfile: Bump to 1.5.3 (diff)
downloadgentoo-1078ef45ca2fb9833e9398fcd4eea37fb37626fa.tar.gz
gentoo-1078ef45ca2fb9833e9398fcd4eea37fb37626fa.tar.bz2
gentoo-1078ef45ca2fb9833e9398fcd4eea37fb37626fa.zip
dev-python/apprise: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.8.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 1de838be9b7f..a6f018c31d56 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.8.0.tar.gz 1651688 BLAKE2B 32458b2a4787c0366db54890b505ca86cf1abee4299d32fd49f8fc8d37b87a6123c902747f97466b061857e7f284ed78c4001e61f587f3b47e17194324217d37 SHA512 312165b1b5c05ee632b5f2631eafc4af2b318881444851966ff6893775caa303b8d8fc819de9c2f8790eb224ac849535c5e5038a2f51dc30d477a503ed48b920
+DIST apprise-1.8.1.tar.gz 1696426 BLAKE2B ddc8966716e89a3e18995370e90f20c080a1249faccdbcf5f28fb22a89dc3f415c33208a5c98352307a28a65b45e305d1b9c3e2df52f6f6f017197a6f893a101 SHA512 b0e5d760ad8fcbecaa51de8e398abbb8766ef8a52bbd9cbd7f77156e4e00194adc1e18e0b6a95c611863ae72162041971408744348a7ea9e6579f4f4aae15f04
diff --git a/dev-python/apprise/apprise-1.8.1.ebuild b/dev-python/apprise/apprise-1.8.1.ebuild
new file mode 100644
index 000000000000..d6fb609e2b6c
--- /dev/null
+++ b/dev-python/apprise/apprise-1.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest