summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-19 14:25:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-19 14:26:31 +0200
commit9f8de1af2f738df5061caa1e4425c88cead9d96f (patch)
treefe01b7f4f9bb6616053b6d7ac04a235ed0b03ad1 /dev-python/async_timeout
parentwww-servers/gunicorn: Enable py3.10 (diff)
downloadgentoo-9f8de1af2f738df5061caa1e4425c88cead9d96f.tar.gz
gentoo-9f8de1af2f738df5061caa1e4425c88cead9d96f.tar.bz2
gentoo-9f8de1af2f738df5061caa1e4425c88cead9d96f.zip
dev-python/async_timeout: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout')
-rw-r--r--dev-python/async_timeout/async_timeout-3.0.1.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/async_timeout/async_timeout-3.0.1.ebuild b/dev-python/async_timeout/async_timeout-3.0.1.ebuild
index 617296b6377f..f4022958304b 100644
--- a/dev-python/async_timeout/async_timeout-3.0.1.ebuild
+++ b/dev-python/async_timeout/async_timeout-3.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
@@ -10,21 +10,20 @@ MY_P=${PN/_/-}-${PV}
DESCRIPTION="Timeout context manager for asyncio programs"
HOMEPAGE="https://github.com/aio-libs/async-timeout"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-S=${WORKDIR}/${MY_P}
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
)"
+distutils_enable_tests pytest
+
python_prepare_all() {
# remove pointless dep on pytest-cov
sed -i -e '/addopts/d' setup.cfg || die
@@ -32,7 +31,3 @@ python_prepare_all() {
rm tests/conftest.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}