summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-31 20:08:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-31 22:22:49 +0300
commitb761faa27de73ef466885cb9a5509a4e01ee6bc4 (patch)
tree7e39709652b265873e22c5edeceb2c46b1b3f38e /dev-python/autopage
parentdev-python/paho-mqtt: enable py3.12 (diff)
downloadgentoo-b761faa27de73ef466885cb9a5509a4e01ee6bc4.tar.gz
gentoo-b761faa27de73ef466885cb9a5509a4e01ee6bc4.tar.bz2
gentoo-b761faa27de73ef466885cb9a5509a4e01ee6bc4.zip
dev-python/autopage: enable py3.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/autopage-0.5.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/autopage/autopage-0.5.1.ebuild b/dev-python/autopage/autopage-0.5.1.ebuild
index 75e2cbae6597..4a683e92c60e 100644
--- a/dev-python/autopage/autopage-0.5.1.ebuild
+++ b/dev-python/autopage/autopage-0.5.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -30,6 +30,14 @@ BDEPEND="
distutils_enable_tests unittest
+src_prepare() {
+ sed -e 's/test_short_streaming_output/_&/' \
+ -e 's/test_interrupt_early/_&/' \
+ -i autopage/tests/test_end_to_end.py || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
unset LESS PAGER
eunittest