summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-02-05 11:09:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-05 19:37:09 +0100
commit23d9e4ede53bdb406f8e12f46b67c738f99a9e67 (patch)
treede84fde54a2dfd6959514d66e6d4647afb197a81 /dev-python/backports-functools-lru-cache
parentdev-python/backports-functools-lru-cache: bump to 1.5 (diff)
downloadgentoo-23d9e4ede53bdb406f8e12f46b67c738f99a9e67.tar.gz
gentoo-23d9e4ede53bdb406f8e12f46b67c738f99a9e67.tar.bz2
gentoo-23d9e4ede53bdb406f8e12f46b67c738f99a9e67.zip
dev-python/backports-functools-lru-cache: remove old
Closes: https://github.com/gentoo/gentoo/pull/7082 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/backports-functools-lru-cache')
-rw-r--r--dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3-r1.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3-r1.ebuild
deleted file mode 100644
index c7d2ae1c1b88..000000000000
--- a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_PN="${MY_PN//-/_}"
-DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}