summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-25 14:14:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-25 14:14:18 +0200
commit0a77c8d6965a272368c7e1f253df4160178d0b9d (patch)
tree3fc006488e65214e1333790703a8f7da100747bc /dev-python/bashate
parentdev-python/scikit-build: Use epytest --deselect instead of rm (diff)
downloadgentoo-0a77c8d6965a272368c7e1f253df4160178d0b9d.tar.gz
gentoo-0a77c8d6965a272368c7e1f253df4160178d0b9d.tar.bz2
gentoo-0a77c8d6965a272368c7e1f253df4160178d0b9d.zip
dev-python/bashate: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest1
-rw-r--r--dev-python/bashate/bashate-2.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
index d2e9a4bc9cbd..b7324fd472a3 100644
--- a/dev-python/bashate/Manifest
+++ b/dev-python/bashate/Manifest
@@ -1 +1,2 @@
DIST bashate-0.6.0.tar.gz 30980 BLAKE2B 5b210edaa44a0652a03f30a641a072dba1482e1ca3b42c6b7140a52349ddb271f0137373a4d2f364032c22c176d6caf14be2635038df8a4e86585773d17a1f97 SHA512 bb64d8de0143bf2662497b1571ce654f4ceeb7d1dea3f625705b609ab70ed3b4bca6266c4eba7c2e7d99a1520fb9566a4a4daefa34c9c16538537b446c1da255
+DIST bashate-2.0.0.tar.gz 29579 BLAKE2B 35cd827a9b5846d0319e6de8fc4bdffbace6b0f669e496aaffa12c44349cc5947a14baecf3b21c3bc4f424796f12b38e273f273f4862949bbae11dfc4b787464 SHA512 f6bacddcad1077d034df0de4313b13aa24ba4c60baa456912d1f40511830a58ca118a72193d4cac358963870e097bee4b0e2ae5a7f7aec42f0ba1663180eb401
diff --git a/dev-python/bashate/bashate-2.0.0.ebuild b/dev-python/bashate/bashate-2.0.0.ebuild
new file mode 100644
index 000000000000..a15011c0549f
--- /dev/null
+++ b/dev-python/bashate/bashate-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest