summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-06 19:34:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-06 20:00:04 +0300
commit2984c7dd763da5b15f244ab4dc332b4690561245 (patch)
tree04840d20f0eb4523c6c42a8512db51ec02d29da4 /dev-python/bashate
parentwww-client/chromium-bin: add 106.0.5249.103 (diff)
downloadgentoo-2984c7dd763da5b15f244ab4dc332b4690561245.tar.gz
gentoo-2984c7dd763da5b15f244ab4dc332b4690561245.tar.bz2
gentoo-2984c7dd763da5b15f244ab4dc332b4690561245.zip
dev-python/bashate: add 2.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest1
-rw-r--r--dev-python/bashate/bashate-2.1.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
index f86877061c80..57ef81fef267 100644
--- a/dev-python/bashate/Manifest
+++ b/dev-python/bashate/Manifest
@@ -1 +1,2 @@
DIST bashate-2.1.0.tar.gz 34717 BLAKE2B 6d25c9fe35f976f5ef24d580cb7ee5a30eb79f68f05de2b6784b79ec93ae090ecbc2a2a09b0cabd4a6a997adef6ccb73f8f258044b0443fa231a403115591202 SHA512 6ef17da86113195d8dae093fddb7c17a365b4cd7816ef0ebb98ac6cda61f52526092f7da6c39c11fba9d709a124970e18e93e267f7d0fb38190e313208f66e98
+DIST bashate-2.1.1.tar.gz 34875 BLAKE2B 9af27813697be12132f58fa13b4f415ce4991795d3e831e651f24a884438775ecaf938f27120ea0fc990f72d8edc5def8ed4bfbc163ca47fabf10a8e350b0b41 SHA512 093ad491b41b73402d316baba894b5f327f07702641f13ece4beb1578d5dfaccbff1e3e0773a799f1acd84443d5a8606288b7c586d5120bb10adcf4427d6f96c
diff --git a/dev-python/bashate/bashate-2.1.1.ebuild b/dev-python/bashate/bashate-2.1.1.ebuild
new file mode 100644
index 000000000000..cd0df55538ec
--- /dev/null
+++ b/dev-python/bashate/bashate-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest