summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-13 22:09:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-13 22:31:13 +0200
commitb2f7c79339d498f244ddfd829a32582554804a2d (patch)
treed95074a1d852322e7fe325d03fa6b9257633062e /dev-python/bashate
parentdev-python/httpcore: Bump to 0.13.7 (diff)
downloadgentoo-b2f7c79339d498f244ddfd829a32582554804a2d.tar.gz
gentoo-b2f7c79339d498f244ddfd829a32582554804a2d.tar.bz2
gentoo-b2f7c79339d498f244ddfd829a32582554804a2d.zip
dev-python/bashate: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest1
-rw-r--r--dev-python/bashate/bashate-2.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
index 65f9120e502f..130aaa69c006 100644
--- a/dev-python/bashate/Manifest
+++ b/dev-python/bashate/Manifest
@@ -1 +1,2 @@
DIST bashate-2.0.0.tar.gz 29579 BLAKE2B 35cd827a9b5846d0319e6de8fc4bdffbace6b0f669e496aaffa12c44349cc5947a14baecf3b21c3bc4f424796f12b38e273f273f4862949bbae11dfc4b787464 SHA512 f6bacddcad1077d034df0de4313b13aa24ba4c60baa456912d1f40511830a58ca118a72193d4cac358963870e097bee4b0e2ae5a7f7aec42f0ba1663180eb401
+DIST bashate-2.1.0.tar.gz 34717 BLAKE2B 6d25c9fe35f976f5ef24d580cb7ee5a30eb79f68f05de2b6784b79ec93ae090ecbc2a2a09b0cabd4a6a997adef6ccb73f8f258044b0443fa231a403115591202 SHA512 6ef17da86113195d8dae093fddb7c17a365b4cd7816ef0ebb98ac6cda61f52526092f7da6c39c11fba9d709a124970e18e93e267f7d0fb38190e313208f66e98
diff --git a/dev-python/bashate/bashate-2.1.0.ebuild b/dev-python/bashate/bashate-2.1.0.ebuild
new file mode 100644
index 000000000000..e38d4d3ab790
--- /dev/null
+++ b/dev-python/bashate/bashate-2.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest