summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-21 08:19:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-21 08:51:07 +0100
commitf76bc9b6cb22901b8390e8efedf9a9214b65fb5c (patch)
treef2b5211ba08c6f4c3c8a587ee81ab64abef67f76 /dev-python/blake3-py-c
parentdev-python/blake3-py: Bump to 0.3.3 (diff)
downloadgentoo-f76bc9b6cb22901b8390e8efedf9a9214b65fb5c.tar.gz
gentoo-f76bc9b6cb22901b8390e8efedf9a9214b65fb5c.tar.bz2
gentoo-f76bc9b6cb22901b8390e8efedf9a9214b65fb5c.zip
dev-python/blake3-py-c: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blake3-py-c')
-rw-r--r--dev-python/blake3-py-c/Manifest1
-rw-r--r--dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/blake3-py-c/Manifest b/dev-python/blake3-py-c/Manifest
index b977cef4177c..4b91e51abc61 100644
--- a/dev-python/blake3-py-c/Manifest
+++ b/dev-python/blake3-py-c/Manifest
@@ -1,2 +1,3 @@
DIST blake3-py-0.3.1.gh.tar.gz 131798 BLAKE2B 6c816bab8d1e432453d4d40f4acc4d33bb45d305a2ab8458dded72bfee6ffd687a016d257dad4c2d656ddd5d765e5ad450e18fdd4af084a51f1973ce56daea68 SHA512 d3901339df9dc3409f8c2407c6f4f02fb9e13e8e7a76d77c06d9f58c6cceea4829cedf71a687fdded8ad70897d3a4833f2b124f39837b0ffa5fb8b907b51fd56
DIST blake3-py-0.3.2.gh.tar.gz 114679 BLAKE2B cf7b6013874c28f2df0ec8c9fb5dc46aa50f2962b80d4d57a087545c915fd490cd11592ca94784ec8a8b9e12380343c2dec1c64afe44eeb8de3f1471678f964b SHA512 695044b108225807eef3016dd8e744c39bff4911a3071e346a4b148a3ba0894f2feef59b7537925cd73acebf6744f3cf8d1161f8d1f801dfd47cb670241b9dea
+DIST blake3-py-0.3.3.gh.tar.gz 114409 BLAKE2B 7514697e2fe58623000dcf457ca5a197b98ca6606e5463b4afb455e36ada3a66865f297272f9e8cde49537442cf5491a7673d64696cba617e085222040b5af66 SHA512 155d8165792935176bf9484b42d6caa715b3c6ff36d266be4d8334fc17a2fdd4a85c5c2c3d53285f21166232a8e558fe9340a8db2bd98ef01d0358809ed28dfb
diff --git a/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild b/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
new file mode 100644
index 000000000000..2f42063712f4
--- /dev/null
+++ b/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-c}
+DESCRIPTION="Python bindings for the BLAKE3 cryptographic hash function"
+HOMEPAGE="https://github.com/oconnor663/blake3-py/"
+SRC_URI="
+ https://github.com/oconnor663/blake3-py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/c_impl
+
+LICENSE="|| ( CC0-1.0 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !dev-python/blake3-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd .. || die
+ epytest
+}