summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 07:34:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 08:02:50 +0200
commit93a8328a0094340823767ef5a0a4e8047c14ef9a (patch)
treec13fd22267a0a0c10ee4493d0923dc6769b92949 /dev-python/boto3/boto3-9999.ebuild
parentdev-python/botocore: Bump to 1.17.31 (diff)
downloadgentoo-93a8328a0094340823767ef5a0a4e8047c14ef9a.tar.gz
gentoo-93a8328a0094340823767ef5a0a4e8047c14ef9a.tar.bz2
gentoo-93a8328a0094340823767ef5a0a4e8047c14ef9a.zip
dev-python/boto3: Bump to 1.14.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3/boto3-9999.ebuild')
-rw-r--r--dev-python/boto3/boto3-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 4e13937c40ec..74bb826bd085 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -14,13 +14,17 @@ SLOT="0"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
inherit git-r3
+ BOTOCORE_PV=${PV}
else
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
fi
RDEPEND="
- >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
"