summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-18 23:59:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-19 00:11:40 +0100
commit167da84a4cf21c1eca0f1bd6b255ae553d935412 (patch)
tree2b0daeebf9c29af8b327781b8bb54c514660f6dd /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.31 (diff)
downloadgentoo-167da84a4cf21c1eca0f1bd6b255ae553d935412.tar.gz
gentoo-167da84a4cf21c1eca0f1bd6b255ae553d935412.tar.bz2
gentoo-167da84a4cf21c1eca0f1bd6b255ae553d935412.zip
dev-python/boto3: Bump to 1.17.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.31.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 69fb4108f1be..2b0533d316e6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -14,4 +14,5 @@ DIST boto3-1.17.27.tar.gz 349887 BLAKE2B 1fde4af489c98b8c4f77660ad278abf6641f70d
DIST boto3-1.17.28.tar.gz 350316 BLAKE2B a6fab50a064fd81337c013bb2516ba2baaa520aa8e7f08418ddaf9b6f0d99a1c8b8eb29b8fee6ab48620430153a0caf4bd296448e1de35a26a972d2e4bbf6df8 SHA512 c26800e18bb254707f0c7e7005b22b1270eae8bf0b8c13f6bcbbe46105ff7439b36c9c80863aefd1037df314abc687bf9b00045d12fb0d3b7337b02605810876
DIST boto3-1.17.29.tar.gz 350960 BLAKE2B 8192d2ea8165b7d10ffdd56b30ba3fadf6f2373c61fc3a9b61713bd299f246ec1b00dce897254f954a93b3b7c150e1cbe8ddf4f0a5894a071e656963d3a06299 SHA512 f662a39aa66ffead103f1d8153ba4175a4905a96b152c1c23030ead3b731cdd008a50dea5f7192d719df2240f35e0290d9b4b3c00e87e77b5d396be7e707be8f
DIST boto3-1.17.30.tar.gz 351634 BLAKE2B e6ad4b4e09ae45684ccd799da45dcf7844149b3dd735a378e90949fd4d533df494b93ef1b97c09057336bae63103bc03f8ce1e9500a5293c617fc8267bc35e89 SHA512 d2b6ac1307ccfe71fba12ea5838726c52c4f45a9467a9b0cf01c4e6898fa0744f6c7ea4cca7294b025dcd21b9e1f15d8aabd15c56e2796035b33e8e3c52f1e45
+DIST boto3-1.17.31.tar.gz 352268 BLAKE2B eefb7bcc3c6809fc03de2f175d5c3cfa750bc8650d56d5ee18608077a88a1c09ea79c2de1ce67f7d48129d5c948a7e5e30ab261c55a381ccf5c030dc42ff0ee0 SHA512 2d603a307575ff04877105ac98068d96b676faaa89b73ef470d9341951d5fcc148a57c7e80867d93bf257854ec700f61e48575ceebe19591091bbf2a68701138
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.31.ebuild b/dev-python/boto3/boto3-1.17.31.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.31.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}