summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-02 06:42:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-02 07:54:32 +0100
commit180e285a7b1377e1803008824442dd37a27c3724 (patch)
treed4a8cf86a058c721714cdd71108f5c0896f3a8f1 /dev-python/boto3
parentdev-python/moto: Bump to 5.0.22 (diff)
downloadgentoo-180e285a7b1377e1803008824442dd37a27c3724.tar.gz
gentoo-180e285a7b1377e1803008824442dd37a27c3724.tar.bz2
gentoo-180e285a7b1377e1803008824442dd37a27c3724.zip
dev-python/boto3: Bump to 1.35.72
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.72.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1ee10b595ba3..42b34dd94a7d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.35.63.gh.tar.gz 891481 BLAKE2B 092f4380aa31e57b3c8f6ef41ea8f0a4272e55f7a71762a532f338482f08782a11d57bdbc9af3630348706c4009bd0d3cd56ef4b2f1394d2d003638717cef860 SHA512 4deab7682b0f4d80a4aa12a8660b7263908411bd8f38692f9fa8820c6a18a4ecc3443e7524794282a0c0f38a4b94a1d09b6737e84ff3e01b9c8ac93abca2a9ce
DIST boto3-1.35.68.gh.tar.gz 901189 BLAKE2B f7449998af169c873319d7b8748035db72c3af7be6499453c9fe61f40cbfd724dce7cf003fe700f6046f43c887768f4c26dd52e491f5734a5ec55c5b54e360c0 SHA512 24582ed20764870e2491a2dc48869089ebc4371a279eff68827ce3a6a962568fc1738e52285fa89a3a846385b498bb233460c1d0ae3177d735ad20b2cef7fea2
DIST boto3-1.35.71.gh.tar.gz 903019 BLAKE2B 48bf56c54a8eaa52c1850078a92cef7e5acb06f2d9d551414d640c6f5c5f381f2edc4ae6f582d9c1578f68d78a272142033bd41caba95577af917a492e995edb SHA512 56df8d30c0d3efc71caa6d629354e1311d944c71b5568b4154fc93c315558d600e4411ccc80abca98cb4a3adf3a3ab4f4dbce22ca06184e11d720f36f33b58d2
+DIST boto3-1.35.72.gh.tar.gz 906195 BLAKE2B 42fa9727d0d35eaa2ea61580538923da30d57e2569dd2ff0b75a2f19ee29b0e5745e93724bf5145296794ee2ee51f3abe1bad017435e68ce9f12c61ccfd3bdf7 SHA512 c54bd53eb6c7753a310dfa26fa9080d5331b0e5ca4cc87c32265f045a615b406e2ace93e41301c6039108ea5be4aa5fd826b875b63253ca4b8c2f8c5892f7bcd
diff --git a/dev-python/boto3/boto3-1.35.72.ebuild b/dev-python/boto3/boto3-1.35.72.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.72.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}