summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:23 +0100
commit4153441797094dbd14e1411629f862a4a645cb93 (patch)
treef0f46cce3de981763d5e16661ad2ee6db4319297 /dev-python/boto3
parentdev-python/botocore: Bump to 1.24.25 (diff)
downloadgentoo-4153441797094dbd14e1411629f862a4a645cb93.tar.gz
gentoo-4153441797094dbd14e1411629f862a4a645cb93.tar.bz2
gentoo-4153441797094dbd14e1411629f862a4a645cb93.zip
dev-python/boto3: Bump to 1.21.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.25.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2fc7ace275fe..655b7451bb59 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -7,4 +7,5 @@ DIST boto3-1.21.21.tar.gz 479513 BLAKE2B 98c67938b271dd7e5d99d06ba5fd046eead6182
DIST boto3-1.21.22.tar.gz 479768 BLAKE2B 3ae647a4c06cb9f7c4c32216dba439ce8bbf346fccf5a8651c08b398bcb7fdb0a4ac81c8d311625d0f50634b90c2f8a02160a19435db836ad05edf0d998a148d SHA512 583a49907339fdb8bb1deaec7683dad6bd0c2836a05cc317a8fc97a17e7b79fd114677fd6342cf6f96b1140bf1bcf9ca0fb1fd3af1c86600e6cfba5bbbf21ec2
DIST boto3-1.21.23.tar.gz 480322 BLAKE2B cbe0e2df766d9bd44be48d0c3304c0883dbdce93ed0ba23d7158b3ae82079b77ccb5a9f017aed89505e87e7b3df32fbe685a9d2dab0aa9174d477052b6e35781 SHA512 cb5d90012809f086f7384b181baff028d87fd25bfc2e4066d86721a3aa25c2d44c32f35ad40136fccf3a1cbf43d9524eb805f871664eb8ef74a805a92dcbf9e9
DIST boto3-1.21.24.tar.gz 481309 BLAKE2B 964010995c28cf185ae03cbbbdaa5a86b5ff855de0e0dfb82aa7a835a3385fa3e53d5343ddaa8a01b6ba28d78d165d6263418b34b2c9edbea0040f553c088fd0 SHA512 18b5c212bc095cfccdfbc38788f5401de60fd9dc0a2c7a6179147b90a3c660d247ce77dd138ffc34382af6d834d6b51be5280d51e45b1f0ac917023f397cea7b
+DIST boto3-1.21.25.tar.gz 482117 BLAKE2B 7f4823fa6045addb4b4ed01e83d1095e9f56dac7c232c5cc744cd956ce0c9840bf70a2901cf4094b0b403ba38129529880b1f1c91d26e9d85db9ca714cfc447b SHA512 2571098f20054d09e691adef67f518321349a55ae3f6eaf3b4ae1d58eefe2e61c67f1bce79366dd017bbaa86e8ffebea12f0d22c712f0b00487fe39e169ce115
DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.25.ebuild b/dev-python/boto3/boto3-1.21.25.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.25.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}