summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 23:44:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 00:01:09 +0200
commit6915e438497e8ecbac412d710f5c3ecfdecce166 (patch)
treed23fa697fa34a5a6bca745fa89ea0c5061b82855 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.87 (diff)
downloadgentoo-6915e438497e8ecbac412d710f5c3ecfdecce166.tar.gz
gentoo-6915e438497e8ecbac412d710f5c3ecfdecce166.tar.bz2
gentoo-6915e438497e8ecbac412d710f5c3ecfdecce166.zip
dev-python/boto3: Bump to 1.17.87
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.87.ebuild56
-rw-r--r--dev-python/boto3/boto3-9999.ebuild8
3 files changed, 61 insertions, 4 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index cfbe961bdefd..64ae47d33edd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.17.83.tar.gz 376963 BLAKE2B 0bdcae1097a8ee4250c08fe639419ea99b83e33
DIST boto3-1.17.84.tar.gz 377284 BLAKE2B dbbc6b8643b720a8a5409c334e268b6de465e7db05684ff5a70d95c91e7e2feff3c3db94ad85f400ac7451e8f37537732ed416602c35bf37955d840701bf5bb4 SHA512 19d224c9bd7135d1de4da807b51f72a3366d5774dba970896388bffb1308b348b001453c0632de5eee8f03bdf0c2b8cf3e9da894e73cb16e10551e060beef5fe
DIST boto3-1.17.85.tar.gz 377940 BLAKE2B 7fdfa25b7fd6467f484dc988bac280b0e4e7044f2a064625efdc5e6f9725b038f08b88f63442452b151541ae4f0ff26ae395816f6422b49474d2e8d93df3a7da SHA512 126e78056b8ac52cba3db5965563c4b6c1451f5aeba2d7d775f358e75f810229102328230e0f5dd1ef3767468106f1d7f3af5575e51422c6b63ef6b509318e70
DIST boto3-1.17.86.tar.gz 378144 BLAKE2B 35d6bfec515c985ead488811e7f2ad021f671e8eee1e63ae1aaade8f4a03dcca228483ec81c4911d12c290b3e4b3363ae92e9153eda83a638258394d0c7b4fcf SHA512 0b267b2333925e830237c830ef5258fa8834fd584f6f4132c012141b4ad5e38b6e6977de019d60f0ba93e3c8b4d9a1036d0c989366145a9d25ac0e5e7e4d39ae
+DIST boto3-1.17.87.tar.gz 378759 BLAKE2B 21ad4c735f34edbd82767043653ed0cee9604f0b36328f40cb22c4f9cd57758e0bc89ae93fd798babc1dded019e2b1531bbffa0574edd7ce3e07515374cd97cf SHA512 da3f2cb772d3f9708f5cbb102907ef58622435d4acdec8fe0abde80511f0734e6cc9739f0652150edc9e4f12039c0c7ee62bcc0059b42d86d5af0e809d779fab
diff --git a/dev-python/boto3/boto3-1.17.87.ebuild b/dev-python/boto3/boto3-1.17.87.ebuild
new file mode 100644
index 000000000000..984809e5128f
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.87.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index f48e380853d3..984809e5128f 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="The AWS SDK for Python"
@@ -17,7 +17,7 @@ if [[ "${PV}" == "9999" ]]; then
BOTOCORE_PV=${PV}
else
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
# botocore is x.(y+3).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"