summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-20 07:43:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-20 09:07:04 +0100
commit4bcebd5d567ff9a55163a2ff62feca1cb3886fd9 (patch)
tree27b91c99178f6182b5a25d728ca9cb4c570fb844 /dev-python/botocore
parentdev-python/moto: Bump to 4.0.12 (diff)
downloadgentoo-4bcebd5d567ff9a55163a2ff62feca1cb3886fd9.tar.gz
gentoo-4bcebd5d567ff9a55163a2ff62feca1cb3886fd9.tar.bz2
gentoo-4bcebd5d567ff9a55163a2ff62feca1cb3886fd9.zip
dev-python/botocore: Bump to 1.29.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.33.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9582794693fc..3f4e1aaa6830 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.29.20.gh.tar.gz 10956292 BLAKE2B 3453a1051056f8f6bc870c66b66d81b
DIST botocore-1.29.29.gh.tar.gz 11020243 BLAKE2B f576fb0ba73b4a9c8a65eedf387a432b30b18db3f657e25ada7c5f3ad647b00ab1f0a855f19bd3ebd897d8e267a14a6d467c29bacb30809b61e7e92ef464ac1e SHA512 fa6457d811137906b0e46302ccabe9623d60ed5cbb588004bbddd0d28ebdaa3aabad3491641b4b69798ed371ddda3e23ea41b930db4f5856e2fa8242dc170571
DIST botocore-1.29.31.gh.tar.gz 11047541 BLAKE2B 7ac038bf914307277db982fa854a6a5832144c1f21b1dc375beb93f3a1c0d765f254066b8741bb5bd98748970611e967882306d11d3f8c9c5f65be318a0dc890 SHA512 cfa49bd47f24cc031d98ce1180fc55f991015b08872ee38024cb70069245f7323d4ac1f9189b0b4dd70516d0bcbe7e5895df221b4eefbfbd83e474d7aee1cd89
DIST botocore-1.29.32.gh.tar.gz 11048130 BLAKE2B 42c1fd07f0501c5815c05ff8ad2d63d1e90e22835e1df274a7a7dbd77d0edd111c6bd596e2c4489a54982629ad5c525cc558db71f5f06d07cc6a80084f3cb274 SHA512 4ae8f60ee36999848944ebb122fbc3bfde0730d5e2450fa25d7f608e277534bce49fef93e2e21db315edfbda795a130b7ce63644f5a3627cbed4b7905bbb1f99
+DIST botocore-1.29.33.gh.tar.gz 11053602 BLAKE2B 746a59340b7a01c46b15d36d735c67db107ccc99ffa20983a15196561f48a3974d5f9d7b82a2eba07ca04b0a9d068bc742fcafe19259b3e76643cd0ca0bb1baf SHA512 efbeeca34ecd759735f91b6dae5bd4f2b32831cdbdc1eb621242b158bc1a707c50de68ab07e894cb207b65601a5b96f592350bd2f2b395a959344d06699ab7e0
diff --git a/dev-python/botocore/botocore-1.29.33.ebuild b/dev-python/botocore/botocore-1.29.33.ebuild
new file mode 100644
index 000000000000..eed342eb3cfa
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.33.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}