summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-29 18:26:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-29 18:29:02 +0300
commit9c8807e1f6459f64d22231021a6ddcf8495ded47 (patch)
treea8ebc86e40c1eca6fa42391c44609a68df04a38d /dev-python/bpython
parentdev-libs/libxslt: fix tests with newer libxml2; patch CVE-2021-30560 (diff)
downloadgentoo-9c8807e1f6459f64d22231021a6ddcf8495ded47.tar.gz
gentoo-9c8807e1f6459f64d22231021a6ddcf8495ded47.tar.bz2
gentoo-9c8807e1f6459f64d22231021a6ddcf8495ded47.zip
dev-python/bpython: enable py3.10
Closes: https://bugs.gentoo.org/812305 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/bpython-0.21.ebuild9
-rw-r--r--dev-python/bpython/files/bpython-0.21-fix-py3.10.patch48
2 files changed, 53 insertions, 4 deletions
diff --git a/dev-python/bpython/bpython-0.21.ebuild b/dev-python/bpython/bpython-0.21.ebuild
index b89b73167409..d815d9186569 100644
--- a/dev-python/bpython/bpython-0.21.ebuild
+++ b/dev-python/bpython/bpython-0.21.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
@@ -34,7 +32,10 @@ BDEPEND="
DOCS=( AUTHORS.rst CHANGELOG.rst )
-PATCHES=( "${FILESDIR}"/${PN}-sphinx-4.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-sphinx-4.patch
+ "${FILESDIR}"/${P}-fix-py3.10.patch
+)
distutils_enable_sphinx doc/sphinx/source --no-autodoc
distutils_enable_tests unittest
diff --git a/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch b/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
new file mode 100644
index 000000000000..5b7c63767820
--- /dev/null
+++ b/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
@@ -0,0 +1,48 @@
+From 78ead4c83d7c47c35ab075dd08114f51c24a709d Mon Sep 17 00:00:00 2001
+From: Thomas Ballinger <thomasballinger@gmail.com>
+Date: Wed, 6 Oct 2021 19:59:38 -0700
+Subject: [PATCH] Test Python 3.10 (#924)
+
+* Test Python 3.10
+* Update tests for Python 3.10
+
+--- a/bpython/test/test_curtsies_painting.py
++++ b/bpython/test/test_curtsies_painting.py
+@@ -139,6 +139,14 @@ def test_completion(self):
+ "└──────────────────────────────┘",
+ "Welcome to bpython! Press <F1> f",
+ ]
++ if sys.version_info[:2] < (3, 10)
++ else [
++ ">>> an",
++ "┌──────────────────────────────┐",
++ "│ and anext( any( │",
++ "└──────────────────────────────┘",
++ "Welcome to bpython! Press <F1> f",
++ ]
+ )
+ self.assert_paint_ignoring_formatting(screen, (0, 4))
+
+--- a/bpython/test/test_interpreter.py
++++ b/bpython/test/test_interpreter.py
+@@ -35,7 +35,19 @@ def test_syntaxerror(self):
+
+ i.runsource("1.1.1.1")
+
+- if sys.version_info[:2] >= (3, 8):
++ if sys.version_info[:2] >= (3, 10):
++ expected = (
++ " File "
++ + green('"<bpython-input-148>"')
++ + ", line "
++ + bold(magenta("1"))
++ + "\n 1.1.1.1\n ^^^^^\n"
++ + bold(red("SyntaxError"))
++ + ": "
++ + cyan("invalid syntax. Perhaps you forgot a comma?")
++ + "\n"
++ )
++ elif (3, 8) <= sys.version_info[:2] <= (3, 9):
+ expected = (
+ " File "
+ + green('"<input>"')